zoj3710 friends(floyd变形)

Friends


Time Limit: 2 Seconds      Memory Limit: 65536 KB

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less thank friends in common, they will become friends in several days. Currently, there are totallyn people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. ThenT cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ mn×(n-1)/2, 0 ≤kn, there will be no duplicated friendship) followed by m lines showing the current friendship. The ith friendship contains two integersui, vi (0 ≤ui, vi <n, ui ≠ vi) indicating there is friendship between personui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

2
0
4


大概思路:

1,数学方法?

2,二进制求交集+搜索+减枝?

3,暴力枚举?

大部分人用的floyd思想递推 :

i认识x,j认识x,那么i就有可能和j是朋友 ,找到i认识j的路径(x数)多等于k即可,如果可以认识,我们动态建路即可





对floyd的理解

    for(k=1;k<=n;k++)

       for(i=1;i<=n;i++)

         for(j=1;j<=n;j++)

            if(...)...

其中k为最对循环次数,我们可以改成:

  while(上一次有更新)

   {

       for(i=1;i<=n;i++)

         for(j=1;j<=n;j++)

           if(...)...+标记更新

   }


#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<memory.h>
using namespace std;
bool map[101][101];
int n,m,k,ans;
void _update()
{
     ans=0;
	 memset(map,false,sizeof(map));	
}
void _in()
{
	    int x,y;
    	scanf("%d%d%d",&n,&m,&k);
    	for(int i=0;i<m;i++){
		    scanf("%d%d",&x,&y);
		    map[x][y]=map[y][x]=true;
		}
}
void _solve()
{
	bool temp=true;
	while(temp)
	{
		temp=false;
		for(int i=0;i<n;i++)
		 for(int j=i+1;j<n;j++)
		 {
				if(map[i][j]) continue;
				int cnt=0; 
				for(int f=0;f<n;f++)
				if(map[i][f]&&map[j][f]) 
				   cnt++;
				   if(cnt>=k) {
					ans++;
					map[i][j]=map[j][i]=true;
					temp=true;
				  }
		 }
	}
    printf("%d\n",ans);
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--){
		_update();
		_in();
		_solve();
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值