HDU1024 DP的优化 最大M子段和问题

14 篇文章 0 订阅
6 篇文章 0 订阅

Max Sum Plus Plus

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31583    Accepted Submission(s): 11174


Problem Description
Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S
1 , S 2 , S 3 , S 4 ... S x , ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i
1 , j 1 ) + sum(i 2 , j 2 ) + sum(i 3 , j 3 ) + ... + sum(i m , j m ) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i
x , j x )(1 ≤ x ≤ m) instead. ^_^
 

Input
Each test case will begin with two integers m and n, followed by n integers S 1 , S 2 , S 3 ... S n .
Process to the end of file.

 

Output
Output the maximal summation described above in one line.
 

Sample Input
  
  
1 3 1 2 3 2 6 -1 4 -2 3 -2 3
 
Sample Output
  
  
6 8
Hint
Huge input, scanf and dynamic programming is recommended.
只能说明自己还是太渣。。。

不加优化:
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<memory.h>
using namespace std;
int dp[2][1000010],a[1000010];
int main()
{
    int n,m,j,i,k,Max;
    while(~scanf("%d%d",&m,&n)){
        Max=0;
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++) scanf("%d",&a[i]);
        for(i=1;i<=m;i++) 
         for(j=m;j<=n;j++){
                dp[i%2][j]=dp[i%2][j-1]+a[j];
                for(k=i-1;k<=j-1;k++)
                 if(dp[(i-1)%2][k]+a[j]>dp[i%2][j]) dp[i%2][j]=dp[(i-1)%2][k]+a[j];
                if(i==m&&dp[i%2][j]>Max) Max=dp[i%2][j];
         }
         printf("%d\n",Max);
    }
    return 0;
}
然后发现k的范围【i-1,j-1】之间可以直接记录一个Maxp
emmmmm,一起做过还是搞忘了
#include<cstdio>
#include<cstdlib>
#include<iostream>
#include<memory.h>
using namespace std;
int dp[2][1000010],a[1000010];
int main()
{
	int n,m,j,i,k,Max,Maxp;
	while(~scanf("%d%d",&m,&n)){
    	Max=-1000000001;
		for(i=1;i<=n;i++) scanf("%d",&a[i]);
		for(i=1;i<=n;i++) dp[0][i]=dp[1][i]=0;
		
		 for(i=1;i<=m;i++) {
		   Maxp=dp[(i-1)%2][i-1];
		   dp[i%2][i]=dp[(i-1)%2][i-1]+a[i];
		   for(j=i+1;j<=n-m+i;j++){
				if(dp[(i-1)%2][j-1]>Maxp) Maxp=dp[(i-1)%2][j-1];
				dp[i%2][j]=dp[i%2][j-1]+a[j];
			    if(Maxp+a[j]>dp[i%2][j]) dp[i%2][j]=Maxp+a[j];
		 }
		}
		 for(i=m;i<=n;i++)
		   if(dp[m%2][i]>Max) Max=dp[m%2][i];
		 printf("%d\n",Max);
	}
	return 0;
}

至于此题的数据范围,呵呵,不存在的。






  
  
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值