HDU1312 Red and Black

                                                      Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6103    Accepted Submission(s): 3887


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
 

Sample Input
  
  
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
 

Sample Output
  
  
45 59 6 13
 

Source
 

Recommend
Eddy

解题思路:简单搜索题,深度优先搜索,广度优先搜索都可以。只要做到两点,题目即可AC。1,把所有能到达的地方走一遍,2,同一点计数不能有重复,走过后标记即可。



#include<cstdio>
#include<queue>
#include<string.h>
using namespace std;
char map[20][20];
int flag[20][20];
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
int n,m;
int sx,sy,maxstep=1;
struct Node
{
    int x;
    int y;
};
void bfs()
{
    queue<Node> Q;
    int x,y;
    int k;
    Node first,next;
    first.x=sx;
    first.y=sy;
    flag[sx][sy]=1;
    Q.push(first);
    while(!Q.empty())
    {
        first=Q.front();
        Q.pop();
        for(k=0;k<4;k++)
        {
            x=first.x+dir[k][0];
            y=first.y+dir[k][1];
            if(x<0||x>=n||y<0||y>=m)
                continue;
            if(map[x][y]=='.'&&flag[x][y]==0)
            {

                next.x=x;
                next.y=y;
                maxstep++;
                Q.push(next);
                flag[x][y]=1;    //记得标记啊
            }
        }
    }
}
int main()
{
    int i,j;
    while(scanf("%d%d",&m,&n)&&n||m)
    {
        memset(flag,0,sizeof(flag));
        maxstep=1;
        for(i=0;i<n;i++)
        {
            scanf("%s",map[i]);
            for(j=0;j<m;j++)
                if(map[i][j]=='@')
                {
                    sx=i;
                    sy=j;
                }
        }
        bfs();
        printf("%d\n",maxstep);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值