POJ_2773_Happy 2006_ 欧几里得算法

Happy 2006
Time Limit: 3000MS
Memory Limit: 65536K
Total Submissions: 10818
Accepted: 3760

Description

Two positive integers are said to be relatively prime to each other if the Great Common Divisor (GCD) is 1. For instance, 1, 3, 5, 7, 9...are all relatively prime to 2006.

Now your job is easy: for the given integer m, find the K-th element which is relatively prime to m when these elements are sorted in ascending order.

Input

The input contains multiple test cases. For each test case, it contains two integers m (1 <= m <= 1000000), K (1 <= K <= 100000000).

Output

Output the K-th element in a single line.

Sample Input

2006 1
2006 2
2006 3

Sample Output

1
3
5 

第一次做欧几里得算法的题,看这位大神的博客看懂的

http://www.cnblogs.com/ACShiryu/archive/2011/08/07/poj2773.html


题目大意就是给出n和k求出第k个与n互素的数

如果知道欧几里德算法的话就应该知道gcd(b×t+a,b)=gcd(a,b)  (t为任意整数)

则如果a与b互素,则b×t+a与b也一定互素,如果a与b不互素,则b×t+a与b也一定不互素

故与m互素的数对m取模具有周期性,则根据这个方法我们就可以很快的求出第k个与m互素的数

假设小于m的数且与m互素的数有k个,其中第i个是ai,则第m×k+i与m互素的数是k×m+ai



#include<stdio.h>
int s[1000005];
int gcd(int a,int b)
{
	if(b==0)
	{
		return a;
	}
	else
	{
		return gcd(b,a%b);
	}
}
int main()
{
    int m,k;
    while(scanf("%d%d",&m,&k)!=EOF)
    {
    	int i;
        int num=0;
        for(i=1;i<=m;i++)   
        {
            if(gcd(m,i)==1)
            {
                s[num++]=i;
            }
        }
        if(k%num==0)
        {
            printf("%d\n",(k/num-1)*m + s[num-1]);
        }
        else
        {
            printf("%d\n",k/num*m + s[k%num-1]);
        }
    }
    return 0;
}

  • 2
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值