NYOJ_1253_Turing equation[【水题】

/*
Turing equation
时间限制:1000 ms  |  内存限制:65535 KB
难度:1

描述
    The fight goes on, whether to store  numbers starting with their most significant digit or their least  significant digit.
    Sometimes  this  is also called  the  "Endian War". The battleground  dates far back into the early days of computer  science.
     Joe Stoy,  in his (by the way excellent)  book  "Denotational Semantics", tells following story:
    "The decision  which way round the digits run is,  of course, mathematically trivial. Indeed,  one early British computer  
    had numbers running from right to left (because the  spot on an oscilloscope tube  runs from left to right, but  in serial
    logic the least significant digits are dealt with first). Turing used to mystify audiences at public lectures when, quite by
    accident, he would slip into this mode even for decimal arithmetic, and write  things  like 73+42=16.  The next version of  
    the machine was  made  more conventional simply  by crossing the x-deflection wires:  this,  however, worried the engineers,
    whose waveforms  were all backwards. That problem was in turn solved by providing a little window so that the engineers
    (who tended to be behind the computer anyway) could view the oscilloscope screen from the back.

    You will play the role of the audience and judge on the truth value of Turing's equations.

输入
    The input contains several test cases. Each specifies on a single line a Turing equation. A Turing equation has the form "a+b=c",
    where a, b, c are numbers made up of the digits 0,...,9. Each number will consist of at most 7 digits. This includes possible
    leading or trailing zeros. The equation "0+0=0" will finish the input and has to be processed, too. The equations will not contain any spaces.
输出
    For each test case generate a line containing the word "TRUE" or the word "FALSE", if the equation is true or false, respectively,
     in Turing's interpretation, i.e. the numbers being read backwards.
样例输入

73+42=16
5+8=13
0001000+000200=00030
0+0=0

样例输出

TRUE
FALSE
TRUE

思路:倒着来,字符串 改为 数字
*/
 
#include <cstdio>
#include <cstring>
using namespace std;
char s[50];
int main()
{
	int i,j,k;
	while(gets(s),strcmp(s,"0+0=0"))
	{
		int num1 = 0,num2 = 0, num3 = 0;
		int len = strlen(s);
		for(i=len-1;i>=0;i--)
		{
			if(s[i]=='=')
				j = i;
			if(s[i]=='+')
				k = i;
		}
		for(i=len-1;i>j;i--)  // c的值  
		{
			num1 = num1 * 10 + s[i] - '0';
		}
		for(j=i-1;j>k;j--) //  b的值 
		{
			num2 = num2 * 10 + s[j] - '0';
		}
		for(k=j-1;k>=0;k--) //a 的值 
		{
			num3 = num3 * 10 + s[k] - '0';
		}
		if(num1==num2+num3)
			printf("TRUE\n");
		else
			printf("FALSE\n");
	}
	return 0;
}
        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值