csu1896——Symmetry

We call a figure made of points is left-right symmetric as it is possible to fold the sheet of paper along a vertical line and to cut the figure into two identical halves.For example, if a figure exists five points, which respectively are (-2,5),(0,0),(2,3),(4,0),(6,5). Then we can find a vertical line x = 2 to satisfy this condition. But in another figure which are (0,0),(2,0),(2,2),(4,2), we can not find a vertical line to make this figure left-right symmetric.Write a program that determines whether a figure, drawn with dots, is left-right symmetric or not. The dots are all distinct.
Input

The input consists of T test cases. The number of test cases T is given in the first line of the input file. The first line of each test case contains an integer N, where N (1 <=N <= 1, 000) is the number of dots in a figure. Each of the following N lines contains the x-coordinate and y-coordinate of a dot. Both x-coordinates and y-coordinates are integers between −10, 000 and 10, 000, both inclusive.
Output

Print exactly one line for each test case. The line should contain 'YES' if the figure is left-right symmetric,and 'NO', otherwise.
Sample Input

3
5
-2 5
0 0
6 5
4 0
2 3
4
2 3
0 4
4 0
0 0
4
5 14
6 10
5 10
6 14

Sample Output

YES
NO

YES

题意:给你一些点,让你去找一条垂直于x轴的直线,使得所有点关于他对称。

解题思路:将这些点排序,先按照纵坐标的从小到大,在安装横坐标从小到大。在第一批纵坐标相等的点中,找到这条直线。然后再用这条直线去验证其他的点。

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cmath>
using namespace std;
const int N=1005;
const double eps=1e-8;//必须小于等于他
struct Node
{
    int x,y;
} p[N];
bool cmp(Node a,Node b)
{
    if(a.y!=b.y)
        return a.y<b.y;
    return a.x<b.x;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%d%d",&p[i].x,&p[i].y);
        sort(p,p+n,cmp);
        int l,r;
        double m;
        l=p[0].x,r=p[0].x;
        int j=1;
        while(j<n)
        {
            if(p[0].y!=p[j].y)
            {
                break;
            }
            l=min(l,p[j].x);
            r=max(r,p[j].x);
            j++;
        }
        m=(l+r)/2.0;//找到对称轴
       // cout<<m<<endl;
        int flag=0;
        for(int i=0;i<n;i++)
        {
            int j=i+1;
            while(p[j].y==p[i].y)//找到纵坐标相等的所有点
            {
                j++;
            }
            int l=i,r=j-1;
           // cout<<l<<" "<<r<<endl;
            while(l<=r)
            {
                double temp=(p[l].x+p[r].x)/2.0;
                if(fabs(temp-m)>eps)//判断前后两个点的对称轴是否为m
                {
                    flag=1;
                    //cout<<"flag"<<l<<" "<<r<<endl;
                    break;
                }
                l++;
                r--;
            }
            if(flag)
                break;
            i=j-1;
        }
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值