1145 Hashing - Average Search Time (25 分)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table first. Then try to find another sequence of integer keys from the table and output the average search time (the number of comparisons made to find whether or not the key is in the table). The hash function is defined to be H(key)=key%TSizewhere TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive numbers: MSize, N, and M, which are the user-defined table size, the number of input numbers, and the number of keys to be found, respectively. All the three numbers are no more than 10​4​​. Then N distinct positive integers are given in the next line, followed by M positive integer keys in the next line. All the numbers in a line are separated by a space and are no more than 10​5​​.

Output Specification:

For each test case, in case it is impossible to insert some number, print in a line X cannot be inserted. where X is the input number. Finally print in a line the average search time for all the M keys, accurate up to 1 decimal place.

Sample Input:

4 5 4
10 6 4 15 11
11 4 15 2

Sample Output:

15 cannot be inserted.
2.8

题目大意:模拟hash表平方试探法

分析:

①首先msize>=用户所给的最小的质数,则首先判断质数与否

②根据公式建立hash表。

③根据要求处理冲突,打印无法插入的数字

④根据查询要求计算平均查询次数,当查询的位置为0即代表没有找到该数字,恰好是这个数字也要跳出循环

代码如下:

 

#include<bits/stdc++.h>
using namespace std;

bool prime(int num)
{
    if (num<=1)  return false;
    for(int i=2;i*i<=num;i++)
    {
        if (num%i==0)  return false;
    }
    return true;
}

int main()
{
  int msize,n,m;
  scanf("%d %d %d",&msize,&n,&m);
  while(!prime(msize))
  {
      msize++;
  }
  vector<int> hash(msize);
  int t;
  for(int i=0;i<n;i++)
  {
      scanf("%d",&t);
      bool flag=false;
      for(int j=0;j<msize;j++)
      {
          int p=hash[(t+j*j)%msize];
          if(p==0)
          {
              flag=true;
              hash[(t+j*j)%msize]=t;
              break;
          }
      }
      if(!flag)  printf("%d cannot be inserted.\n",t);
  }
  float cmp=0.0;
  for(int i=0;i<m;i++)
  {
      scanf("%d",&t);
      int c=1;
      for(int j=0;j<msize;j++)
      {
          if(hash[(t+j*j)%msize]==t||hash[(t+j*j)%msize]==0)
          {
              break;
          }
          c++;
      }
      cmp=cmp+c;
  }

    printf("%.1f",cmp/m);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值