1142 Maximal Clique (25 分)

clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:

For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:

8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1

Sample Output:

Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

题目大意:

题中给出一个团的概念,在由点和线组成的图中,如果有一堆点(也就是点的集合,这么说可能有点不严谨但是会好理解一些),它们之间两两相邻,那么他们就是一个团(clique),如果这堆点不仅能两两相邻,而且它们不能通过新加入一个点进而形成一个更大的团,那么这个团就叫做最大团。

题目给一个图,再给出k个询问,每个询问给你一个点集,问你它们是团,是最大团吗
 

代码如下: 

#include <bits/stdc++.h>
using namespace std;
int way[300][300]={0};
int a[10000];
int judge(int x,int k)
{
    int flag=0;
    if (x!=-1)
        a[k++]=x;
    for(int i=0;i<k;i++)
      if(!flag)
      for (int j=i+1;j<k;j++)
       if (!way[a[i]][a[j]])
        {
            flag=1;
            break;
        }
        return flag;
}

int main() {
   int n,m;
   cin>>n>>m;
   for (int i=0;i<m;i++)
   {
       int x,y;
       cin>>x>>y;
       way[x][y]=way[y][x]=1;
   }
    int p;
    cin>>p;
   while (p--)
   {
       int k;
       cin>>k;
       for (int i=0;i<k;i++)
         scanf("%d",&a[i]);
        if(judge(-1,k))
       {
           cout<<"Not a Clique"<<endl;
           continue;
       }
       for(int i=1;i<=n;i++)
        {
            int flag = 0;
        for (int j=0;j<k;j++)
        if (way[a[j]][i])
          {
             flag=1;break;
          }
       if (flag)
       {
           if(!judge(i,k))
           {
               cout<<"Not Maximal"<<endl;
               goto out;
           }
       }
   }
   cout<<"Yes"<<endl;
   out:;
  }
          return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值