Minimum Inversion Number_HDU1394(树状数组)

题目

Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 31439 Accepted Submission(s): 17797

Problem Description
The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output
For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2

Sample Output

16

想法

挺简单的一个题,就是树状数组+修改。

比如目前最前面的为ai,那么把它放到后面,和之前相比:
1.删除它对后面所有数字的影响(就是他后面比他小的数,所贡献的逆序对-1)
2.加上他到达最后时所贡献的逆序对

实现的代码

#include<iostream>
#include<cstring>
#include<algorithm>

using namespace std;
const int N = 5e5 + 1e2;
typedef long long int LL;
const int inf = 0x3f3f3f3f;

int n , num[N];
LL cnum[N] ;

int lowbit(int x){
	return x&(-x);
}
void add(int index , int num){
	for(int i = index ; i <= n ; i += lowbit(i)){
		cnum[i] += num;
	}
}
LL getSum(int index){
	LL res = 0;
	for(int i = index ; i > 0 ; i -= lowbit(i)){
		res += cnum[i];
	}
	return res;
}
int main(){
	ios::sync_with_stdio(false);
	int i , j ;
	LL Min = inf;
	while(cin>>n){
		memset(cnum , 0 , sizeof(cnum));
		for(i = 1 ; i <= n ; i ++ ){
			cin>>num[i];num[i]++;
		}
		LL res = 0;
		for(i = 1 ; i <= n ; i ++ ){
			add(num[i],1);
			res += (i-getSum(num[i]));
		}
		Min = res;
		for(i = 1 ; i < n ; i ++ ){
			res -= getSum(num[i])-1;
			res += (n-getSum(num[i]));
			Min = min(Min , res);
		}
		cout<<Min<<endl;
	}
	return 0;
}

做的比较急,没看到多组输入和ai的范围为[0-m-1],写了离散化,而且还一直WA。掩饰一下彩笔本色

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值