杭电1041 Computer Transformation

                                 Computer Transformation

Problem Description

A sequence consisting of one digit, the number 1 is initially written into a computer. At each successive time step, the computer simultaneously tranforms each digit 0 into the sequence 1 0 and each digit 1 into the sequence 0 1. So, after the first time step, the sequence 0 1 is obtained; after the second, the sequence 1 0 0 1, after the third, the sequence 0 1 1 0 1 0 0 1 and so on.
How many pairs of consequitive zeroes will appear in the sequence after n steps?

 

Input

Every input line contains one natural number n (0 < n ≤1000).

 

Output

For each input n print the number of consecutive zeroes pairs that will appear in the sequence after n steps.

 

Sample Input

  
  
2 3

 

Sample Output

  
  
1 1

AC代码:

/*这一题首先要分析、找规律:shu[i]=shu[i-1]*2+1(i是偶数)
                            shu[i]=shu[i-1]*2-1(i是奇数)
又因为计算结果非常大,所以要用到大数*/
#include<stdio.h>
#include<string.h>
int shu[1010][1010];//定义数组来存放 0—1000的所有运算结果
int main()
{
    int i,j,k,n;
    memset(shu,0,sizeof(shu));//将数组 shu 清零
    shu[0][0]=0;
    shu[1][0]=0;
    for(i=2;i<=1000;i++)//根据规律计算每个数的结果
    {
 for(j=0;j<1010;j++)
 {
  shu[i][j]=shu[i][j]+shu[i-1][j]*2;
  if(shu[i][j]>=10)
  {
   shu[i][j]=shu[i][j]-10;
   shu[i][j+1]=shu[i][j+1]+1;
  }
 }
  if(i%2==0)
  {
     shu[i][0]=shu[i][0]+1;
     if(shu[i][0]>=10)
     {
     shu[i][0]=shu[i][0]-10;
     for(k=1;k<1010;k++)
     {
      shu[i][k]=shu[i][k]+1;
      if(shu[i][k]<10)
       break;
      else
       shu[i][k]=shu[i][k]-10;
     }
     }
  }
    if(i%2!=0)
  {
     shu[i][0]=shu[i][0]-1;
     if(shu[i][0]<0)
     {
     shu[i][0]=shu[i][0]+10;
     for(k=1;k<1010;k++)
     {
      shu[i][k]=shu[i][k]-1;
      if(shu[i][k]>0)
       break;
      else
       shu[i][k]=shu[i][k]+10;
     }
     }
  }
 }
  while(scanf("%d",&n)!=EOF)
  {
   for(i=1009;i>=0&&shu[n][i]==0;i--);//注意输出结果时不能输出前面的 0 
   if(i>=0)
   {
    for(;i>=0;i--)
     printf("%d",shu[n][i]);
   }
   else
    printf("0");
   printf("\n");
  }
  return 0;
}
            


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值