杭电ACM 1028 Ignatius and the Princess III(纯母函数模板)

                                         Ignatius and the Princess III

Problem Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input

  
  
4 10 20
 

Sample Output

  
  
5 42 627
 
题目大意:输入数n,输出有多少种方法使它们的和等于n
解题思路:用到了母函数,直接套用母函数的模板
 
AC代码:
#include<stdio.h>
#include<string.h>
int main()
{
 int c1[200],c2[200],i,j,k,n;
 //c1用来存放表达式的系数,c2用来存放中间结果
 while(scanf("%d",&n)!=EOF)
 {
   for(i=0;i<=n;i++)//初始化第一个表达式的系数
   {
    c1[i]=1;
    c2[i]=0;
   }
   for(i=2;i<=n;i++)//i表示第几个表达式,i从2开始赋值表示从第二个表达式开始,因为有无限个所以有n个表达式
   {
    for(j=0;j<=n;j++)//用累乘后的表达式再从第一个开始直到最后一个乘上另一个表达式
    {
     for(k=0;k+j<=n;k=k+i)//k为第j个变量的指数,第i个表达式每次累加i             
     {
      c2[k+j]=c2[k+j]+c1[j];
     }
    }
     for(j=0;j<=n;j++)//算完一个表达式后要更新一次
     {
    c1[j]=c2[j];
    c2[j]=0;
     }
  }
  printf("%d\n",c1[n]);
 }
 return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值