第九届河南省程序设计大赛 1277-Decimal integer conversion (java)

1277-Decimal integer conversion


内存限制:64MB  时间限制:1000ms  Special Judge: No

accepted:5  submit:7

题目描述:

XiaoMing likes mathematics, and he is just learning how to convert numbers between different bases , but he keeps making errors since he is only 6 years old. Whenever XiaoMing converts a number to a new base and writes down the result, he always writes one of the digits wrong. For example , if he converts the number 14 into binary (i.e., base 2), the correct result should be "1110", but he might instead write down "0110" or "1111". XiaoMing never accidentally adds or deletes digits, so he might write down a number with a leading digit of " 0" if this is the digit she gets wrong. Given XiaoMing 's output when converting a number N into base 2 and base 3, please determine the correct original value of N (in base 10). (N<=10^10) You can assume N is at most 1 billion, and that there is a unique solution for N. 

输入描述:

The first line of the input contains one integers T, which is the nember of test cases (1<=T<=8) Each test case specifies: * Line 1: The base-2 representation of N , with one digit written incorrectly. * Line 2: The base-3 representation of N , with one digit written incorrectly.

输出描述:

For each test case generate a single line containing a single integer , the correct value of N

样例输入:

复制
1
1010
212

样例输出:

14

提示:


这道题只要算出每一位二进制或三进制错位后的十进制,相等就是结果。

import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
	  Scanner sc=new Scanner(System.in);
	  int T=sc.nextInt();
	  while(T-->0)
	  {   
		  int[] a=new int[50];//二进制数组
		  int[] b=new int[105];//三进制数组
		  char[] s1=new char[50];//二进制字符串
		  char[] s2=new char[50];//三进制字符串
		  String str1=sc.next();
		  String str2=sc.next();
		  s1=str1.toCharArray();
		  s2=str2.toCharArray();
		  int len1=str1.length();
		  int len2=str2.length();
		  for(int i=0;i<len1;i++)
		  {
			  s1[i]= (char) ((s1[i]-'0'+1)%2+'0');//对二进制错位
			  //System.out.print(s1[i]+" ");
			  for(int j=0;j<len1;j++)
				  a[i]+=(s1[j]-'0')*(int)(Math.pow(2,len1-1-j));
			  //System.out.print(a[i]+" ");
			  s1[i]=(char) ((s1[i]-'0'+1)%2+'0');//对二进制还原
		  }
		  int k=0;
		  for(int i=0;i<len2;i++)
		  {
			  s2[i]=(char) ((s2[i]-'0'+1)%3+'0');//对三进制错位
			  //System.out.print(s2[i]+" ");
			  for(int j=0;j<len2;j++)
				  b[k]+=(s2[j]-'0')*(int)(Math.pow(3,len2-1-j));
			  //System.out.print(b[k]+" ");
			  k++;
			  s2[i]=(char) ((s2[i]-'0'+1)%3+'0');//每次累加1,错位
			  //System.out.print(s2[k]+" ");
			  for(int j=0;j<len2;j++)
				  b[k]+=(s2[j]-'0')*(int)(Math.pow(3,len2-1-j));
			  //System.out.print(b[k]+" ");
			  k++;
			  s2[i]=(char) ((s2[i]-'0'+1)%3+'0');//对三进制还原
		  }
		  for(int i=0;i<len1;i++)
			  for(int j=0;j<k;j++)
			  {
				  if(a[i]==b[j])
				  {
					  System.out.println(a[i]);
					  break;
				  }
			  }
	  }
	  

	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值