android

1.

今天做android的开发,新建了一个xml文件,然后就报Error in an XML file: aborting build 错误。

解决方案:

要建Android XML File才行~~~
直接建XML file就出这个问题,而且还没有代码提示。

2.
如果你用的是myeclipse 6.0 而且 在使用 @Override 时出现以下错误: The method XXXXXX   of type XXXXXXXXX must override a superclass method 那是因为你的Compiler 是jdk1.5,只要把它改为 1.6就可以了方法: 1. window ->preferences... -> java -> Compiler 2. Compiler compliance level : 6.0 3.Apply 4. ok 5.完成

3.今天想弄弄个布局文件,只是很简单的一个布局,检查了很多遍,里面完全没有什么语法错误,可是保存时,Eclipse还是老报这个错误


纠结了很久。后来终于发现原因了。

如果<?xml version="1.0" encoding="utf-8"?>这句话不放在顶格紧靠左边记住:一定要放在第一行紧靠左边,就算放在第一行空了两格或者第二行没空格都会报错),就会编译报这错误。所以以后大家出现这问题时一定要谨记,否则影响心情啊,谁晓得连这个都会出现问题呢,检查很多遍是很难检查出来这问题的。

 

3,这个主要是导入项目的属性文件中的sdk版本与当前开发环境的sdk版本不同,在这里只需要稍微修改一
下项目的属性文件就可以,在android项目的default.properties 中的修改target的值,如果是2.1版本就将target的值改为android 7, 如果开发环境是2.3版本,就将target改为android 9,总之这个值与使用的android sdk版本的关,这个修改完后,右键点击项目选择 Android Tools->Fix Project Properties,这时你会看到项目所引用的android.jar已经自动导入到项目中。或者修改完target的值后,只要保存一下就可以成功。

 

4,[2011-01-07 09:38:11 - DeviceMonitor]Adb connection Error:远程主机强迫关闭了一个现有的连接。
[2011-01-07 09:38:12 - DeviceMonitor]Connection attempts: 1
[2011-01-07 09:38:14 - DeviceMonitor]Connection attempts: 2
[2011-01-07 09:38:16 - DeviceMonitor]Connection attempts: 3

答案:adb 连接断了就这效果吧。

开着eclipse
运行adb kill-server
5,ActivityManager: Error: Activity class {} does not exist.

答案:删掉project,再重新import,选择已存在project选项,然后再运行就可以了,具体原因不知道

阅读更多 登录后自动展开
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页