POJ 2386 Lake Counting(DFS)

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 29399 Accepted: 14721

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
 
#include<stdio.h>
#include<string.h>
char a[110][110];
int n,m,sum;	
int NEXT[8][2]={{-1,-1},{-1,0},{-1,1},{0,-1},{0,1},{1,0},{1,1},{1,-1}};//给出八个方向的差值 
void DFS(int r,int c)
{
for(int i=0;i<8;i++)
{
	int tx=r+NEXT[i][0];//横 
	int ty=c+NEXT[i][1];// 纵 
	if(tx>=0&&tx<n&&ty>=0&&ty<m&&a[tx][ty]=='W')//判断是否越界和八个方向是否有水池 
	{
		a[tx][ty]='.';//找到就填坑
		DFS(tx,ty);
	}
}
}
int main()
{
	    scanf("%d%d",&n,&m);
		memset(a,'.',sizeof(a));//全部初始化的话就不用再DFS函数里面判断越界情况了 
		for(int i=0;i<n;i++)
		scanf("%s",a[i]); 
  //	for(int i=0;i<n;i++)
	//	{for(int j=0;j<m;j++)
	//	printf("%c",a[i][j]);
	//  printf("\n");
	//	} 
	for(int i=0;i<n;i++)
	for(int j=0;j<m;j++)
	{
		if(a[i][j]=='W')//判断是否是水池 
		{
			a[i][j]='.';//填坑 
			DFS(i,j);
			sum++;//连通着的的水池全部找完就sum++ 
		}
	} 
	printf("%d\n",sum);	
	return 0;
} 

灰灰灰过~

                
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值