Joseph
Time Limit: 1000MS | Memory Limit: 10000K | |
Total Submissions: 53977 | Accepted: 20601 |
Description
The Joseph's problem is notoriously known. For those who are not familiar with the original problem: from among n people, numbered 1, 2, . . ., n, standing in circle every mth is going to be executed and only the life of the last remaining person will be saved. Joseph was smart enough to choose the position of the last remaining person, thus saving his life to give us the message about the incident. For example when n = 6 and m = 5 then the people will be executed in the order 5, 4, 6, 2, 3 and 1 will be saved.
Suppose that there are k good guys and k bad guys. In the circle the first k are good guys and the last k bad guys. You have to determine such minimal m that all the bad guys will be executed before the first good guy.
Input
The input file consists of separate lines containing k. The last line in the input file contains 0. You can suppose that 0 < k < 14.
Output
The output file will consist of separate lines containing m corresponding to k in the input file.
Sample Input
3
4
0
Sample Output
5
30
Source
#include <iostream>
using namespace std;
int k,m;
int a[14];
bool Can(int k,int m) //检测是否符合前k个出环的要求
{
int i = 0;
int len = 2*k;
while (len>k)
{
i = (i+m-1)%len;
if(i<k) return 0;
len--;
}
return 1;
}
void Construct()
{
int i,j;
for (i=1;i<14;i++)
{
for(j=k+1;;j++)
{
if(Can(i,j))
{
a[i] = j;
break;
}
}
}
}
int main()
{
Construct();
while (cin>>k) //0 < k < 14
{
if(k==0)break;
cout<<a[k]<<endl;
}
return 0;
}
<iostream>
using namespace std;
int k,m;
int a[14];
bool Can(int k,int m) //检测是否符合前k个出环的要求
{
int i = 0;
int len = 2*k;
while (len>k)
{
i = (i+m-1)%len;
if(i<k) return 0;
len--;
}
return 1;
}
void Construct()
{
int i,j;
for (i=1;i<14;i++)
{
for(j=k+1;;j++)
{
if(Can(i,j))
{
a[i] = j;
break;
}
}
}
}
int main()
{
Construct();
while (cin>>k) //0 < k < 14
{
if(k==0)break;
cout<<a[k]<<endl;
}
return 0;
}