Openjudge 2.4.7909 统计数字 C++实现

描述

某次科研调查时得到了n个自然数,每个数均不超过1500000000(1.5*109)。已知不相同的数不超过10000个,现在需要统计这些自然数各自出现的次数,并按照自然数从小到大的顺序输出统计结果。

输入

包含n+1行:
第一行是整数n,表示自然数的个数;
第2~n+1每行一个自然数。

40%的数据满足:1<=n<=1000;
80%的数据满足:1<=n<=50000;
100%的数据满足:1<=n<=200000,每个数均不超过1500 000 000(1.5*10^9)。

输出

包含m行(m为n个自然数中不相同数的个数),按照自然数从小到大的顺序输出。每行输出两个整数,分别是自然数和该数出现的次数,其间用一个空格隔开。

样例输入

8
2
4
2
4
5
100
2
100

样例输出

2 3
4 2
5 1
100 2
#include <iostream>
#include<bits/stdc++.h>
#include <vector>
#include <algorithm>
#include <cmath>
#include<math.h>
#include <cstring>
#include<string>
#include<cstdio>
#include<cstdlib>

using namespace std;
typedef struct Num {
    long long num;
    int times;
};
Num test[200005];

struct Rule3 {
    bool operator()(const Num &a1, const Num &a2) {
        return a1.num < a2.num;
    }
};

int main() {
    int n;
    cin >> n;
    int i;
    for (i = 0; i < n; ++i) {
        cin >> test[i].num;
        test[i].times = 1;

    }
    sort(test, test + n, Rule3());
    for (int i = 0; i < n; ++i) {
        if (test[i].num == test[i + 1].num) {
            test[i + 1].times += test[i].times;
        } else {
            cout << test[i].num << ' ' << test[i].times << endl;
        }
    }
    return 
  • 8
    点赞
  • 13
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值