HDU 1394 线段树

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 16217    Accepted Submission(s): 9867


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16

题目要求出最小的逆序数。

逆序数概念如下:

在一个排列中,如果一对数的前后位置与大小顺序相反,即前面的数大于后面的数,那么它们就称为一个 逆序。一个排列中逆序的总数就称为这个排列的 逆序数。逆序数为偶数的排列称为 偶排列;逆序数为奇数的排列称为 奇排列。如2431中,21,43,41,31是逆序,逆序数是4,为偶排列。
也是就说,对于n个不同的元素,先规定各元素之间有一个标准次序(例如n个 不同的自然数,可规定从小到大为标准次序),于是在这n个元素的任一排列中,当某两个元素的先后次序与标准次序不同时,就说有1个逆序。一个排列中所有逆序总数叫做这个排列的逆序数。

首先要用线段树求出m=0时的逆序数,之后就可以用公式 sum=sum-a[i]+n-1-a[i] 得出之后的逆序数。时间复杂度为O(nlogn)。


线段树中记录从x~y中的数出现过的个数,每次求一个数的逆序数后都对线段树进行一次更新。


#include<iostream>
#include<stdio.h>
#include<math.h>
#include<string.h>
#include<vector>
#include<queue>
#include<map>
#include<stack>
#include<queue>
#include<algorithm>
using namespace std;
const int MAX=0x7fffffff;
int min(int a,int b)
{
    if(a<b)return a;
    else return b;
}
int max(int a,int b)
{
    if(a>b)return a;
    else return b;
}
const int N=200005;
int sumtree[N*4+10],a[N+10];//sumtree中记录每个点的出现个数
void build(int start,int end,int node)
{
    sumtree[node]=0;
    if(start==end)
        return;
    else 
    {
        build(start,(start+end)/2,node*2);
        build((start+end)/2+1,end,node*2+1);
    }
}
int searchsum(int node,int start,int end,int left,int right)//搜索所有比a[i]大的数
{
    int mid=(start+end)/2;
    if(left<=start&&right>=end)
        return sumtree[node];
    int sum=0;
    if(left<=mid) sum+=searchsum(node*2,start,mid,left,right);
    if(right>mid) sum+=searchsum(node*2+1,mid+1,end,left,right);
    return sum;
}
void changetree(int node,int pos,int left,int right)//对a[i]计数
{
    if(left==right)
        {
            sumtree[node]++;
            return;
    }
    int mid=(left+right)/2;
    if(pos<=mid) changetree(node*2,pos,left,mid);
    if(pos>mid) changetree(node*2+1,pos,mid+1,right);
    sumtree[node]=sumtree[node*2]+sumtree[node*2+1];
}
int n,m;
int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    while(~scanf("%d",&n))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        build(0,n-1,1);
        int sum=0;
        for(int i=0;i<n;i++)
        {
            sum+=searchsum(1,0,n-1,a[i],n-1);
            changetree(1,a[i],0,n-1);
        }
        int Min=sum;
        for(int i=0;i<n;i++)
        {
            
            sum=sum-a[i]+n-1-a[i];
            Min=min(Min,sum);
        }
        printf("%d\n",Min);
    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值