poj 2828(线段树单点更新)

Buy Tickets
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 18822 Accepted: 9342

Description

Railway tickets were difficult to buy around the Lunar New Year in China, so we must get up early and join a long queue…

The Lunar New Year was approaching, but unluckily the Little Cat still had schedules going here and there. Now, he had to travel by train to Mianyang, Sichuan Province for the winter camp selection of the national team of Olympiad in Informatics.

It was one o’clock a.m. and dark outside. Chill wind from the northwest did not scare off the people in the queue. The cold night gave the Little Cat a shiver. Why not find a problem to think about? That was none the less better than freezing to death!

People kept jumping the queue. Since it was too dark around, such moves would not be discovered even by the people adjacent to the queue-jumpers. “If every person in the queue is assigned an integral value and all the information about those who have jumped the queue and where they stand after queue-jumping is given, can I find out the final order of people in the queue?” Thought the Little Cat.

Input

There will be several test cases in the input. Each test case consists of N + 1 lines where N (1 ≤ N ≤ 200,000) is given in the first line of the test case. The next N lines contain the pairs of values Posi and Vali in the increasing order of i (1 ≤ iN). For each i, the ranges and meanings of Posi and Vali are as follows:

  • Posi ∈ [0, i − 1] — The i-th person came to the queue and stood right behind the Posi-th person in the queue. The booking office was considered the 0th person and the person at the front of the queue was considered the first person in the queue.
  • Vali ∈ [0, 32767] — The i-th person was assigned the value Vali.

There no blank lines between test cases. Proceed to the end of input.

Output

For each test cases, output a single line of space-separated integers which are the values of people in the order they stand in the queue.

Sample Input

4
0 77
1 51
1 33
2 69
4
0 20523
1 19243
1 3890
0 31492

Sample Output

77 33 69 51
31492 20523 3890 19243

Hint

The figure below shows how the Little Cat found out the final order of people in the queue described in the first test case of the sample input.



题意:

有一个队列,给出一组数,代表每个人的姓名和在队列中的位置,如果后面的人选定的位置上有人时,位置上的人就要向后移,当前的人进入位置。

思路:

因为后来的人必定在他所要求的位置上,所以应该从后向前判断位置,对线段树进行单点更新。


#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<vector>
#include<bitset>
#include<queue>
#include<stack>
#include<list>
#include<set>
#include<math.h>
#include<map>
using namespace std;
struct point
{
	int pos,name;
};
point a[200005];
const int N=200005;  
int sumtree[N*4+10],p[N+10];//sumtree中记录每个点的出现个数  
void build(int start,int end,int node)  
{  
    sumtree[node]=end-start+1;  
    if(start==end)  
        return;  
    else   
    {  
        build(start,(start+end)/2,node*2);  
        build((start+end)/2+1,end,node*2+1);  
    }  
}  
int searchsum(int node,int start,int end,int left,int right)//搜索所有比a[i]大的数  
{  
    int mid=(start+end)/2;  
    if(left<=start&&right>=end)  
        return sumtree[node];  
    int sum=0;  
    if(left<=mid) sum+=searchsum(node*2,start,mid,left,right);  
    if(right>mid) sum+=searchsum(node*2+1,mid+1,end,left,right);  
    return sum;  
}  
void changetree(int node,int pos,int left,int right,int pp)//对a[i]计数  
{  
	sumtree[node]--;
    if(left==right)  
        {  
			p[left]=a[pp].name;  
            return;  
    }  
    int mid=(left+right)/2;  
    if(pos<=sumtree[node*2]) changetree(node*2,pos,left,mid,pp);  
	else {
		pos-=sumtree[node*2];
		changetree(node*2+1,pos,mid+1,right,pp);  
	}
}  

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		build(0,n-1,1);
		for(int i=0;i<n;i++)
			scanf("%d%d",&a[i].pos,&a[i].name);
		for(int i=n-1;i>=0;i--)
			changetree(1,a[i].pos+1,0,n-1,i);
		for(int i=0;i<n;i++)
		{
			if(i==0)
			printf("%d",p[i]);
			else printf(" %d",p[i]);
		}
		printf("\n");
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值