hdu 1325

Is It A Tree?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17755    Accepted Submission(s): 3985


Problem Description
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties. 
There is exactly one node, called the root, to which no directed edges point. 

Every node except the root has exactly one edge pointing to it. 

There is a unique sequence of directed edges from the root to each node. 

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.



In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not. 

 

Input
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero. 
 

Output
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1). 
 

Sample Input
  
  
6 8 5 3 5 2 6 4 5 6 0 0 8 1 7 3 6 2 8 9 7 5 7 4 7 8 7 6 0 0 3 8 6 8 6 4 5 3 5 6 5 2 0 0 -1 -1
 

Sample Output
  
  
Case 1 is a tree. Case 2 is a tree. Case 3 is not a tree.
 

Source
 
并查集的应用
注意:成树的条件:不能成环,任意两点有且只有一条路,并且两或多个个箭头不能指向同一个点,例如:1 2 3 2 4 2 0 0;它就不是树!!
它与hdu 1272 相似,但唯一不同的是该题是有向图,而小希的迷宫这题是无向图!!
 
 #include<stdio.h>
 #include<string.h>
 #include<iostream>
 using namespace std;
 #include<algorithm>
 int bin[100005],sign,a[100005];
 int findx(int x)
 {  int r=x,f;
     while(r!=bin[r])
       r=bin[r];
        return r;
 }
 void fun(int x,int y)
 {
     int tx,ty;
     tx=findx(x);
     ty=findx(y);
     if(tx!=ty)
         bin[tx]=ty;
     else sign=1;
 }
 int main()
 {
     int n,m,i,j,sum,h=1,vis[100005],f;
     while( scanf("%d %d",&n,&m)&&n>=0&&m>=0)
     {
           f=0;
       if(n==0&&m==0){printf("Case %d is a tree.\n",h++);continue;}
         sign=0;a[f++]=m;
         memset(vis,0,sizeof(vis));
         for(i=1;i<100005;i++)
            bin[i]=i;
            vis[n]=1;vis[m]=1;
           fun(n,m);
        while((m+n)!=0)
        {
            scanf("%d %d",&n,&m);
            a[f++]=m;
            if(n+m==0)break;
            vis[n]=1;vis[m]=1;
              fun(n,m);
        }
        sort(a,a+f);
        for(i=0;i<f-1;i++)
            if(a[i]==a[i+1])sign=1;//判断是否有多个箭头指向一个点!!!
        for(sum=0,j=1;j<100005;j++)
        {
            if(bin[j]==j&&vis[j])
                  sum++;
               if(sum>1){sign=1;break;}
        }
        if(sign)printf("Case %d is not a tree.\n",h);
        else printf("Case %d is a tree.\n",h);
        h++;
     }
     return 0;
 }


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值