pat 1020. Tree Traversals (25)

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:
4 1 6 3 5 7 2

 已知二叉树后序和中序遍历,求层序遍历。
重建二叉树后,层序遍历就bfs二叉树就可以了。
#include<iostream>
using namespace std;
#include<string.h>
#include<stdio.h>
#include<queue>
#define MS(a,b) memset(a,b,sizeof(a))
typedef struct node
{
    int data;
    node *left,*right;
}*Tree;
Tree T;
int ans[100],in[100],post[100],n;
void Build(int l1,int r1,int l2,int r2,Tree &T)
{
    int i;
    T=new node();
    for(i=l1;i<=r1;i++)//求根结点
        if(in[i]==post[r2])
              break;
        T->data=post[r2];
    if(i==l1)
        T->left=NULL;
    else Build(l1,i-1,l2,l2+i-l1-1,T->left);//递归求左子树
    if(i==r1)
       T->right=NULL;
    else Build(i+1,r1,r2-(r1-i),r2-1,T->right);//递归求右子树
}
int j;
void levelorder(Tree  T)
{
     queue<Tree>q;
     q.push(T);
     while(!q.empty())
     {
        Tree root=q.front();
        q.pop();
        ans[j++]=root->data;
        if(root->left!=NULL)
            q.push(root->left);
        if(root->right!=NULL)
            q.push(root->right);
     }
}
int main()
{
    /*#ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    freopen("out.txt","w",stdout);
    #endif*/
    int i;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
         scanf("%d",&post[i]);
    for(i=1;i<=n;i++)
        scanf("%d",&in[i]);
    Build(1,n,1,n,T);
    j=0;
    levelorder(T);
    for(i=0;i<j-1;i++)
     printf("%d ",ans[i]);
     printf("%d\n",ans[i]);
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值