Time Limit: 18000/9000 MS (Java/Others) Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 3234 Accepted Submission(s): 1397
Total Submission(s): 3234 Accepted Submission(s): 1397
Problem Description
John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces
n
chips today, the
i
-th chip produced this day has a serial number
si
.
At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
which i,j,k are three different integers between 1 and n . And ⊕ is symbol of bitwise XOR.
Can you help John calculate the checksum number of today?
At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)⊕sk
which i,j,k are three different integers between 1 and n . And ⊕ is symbol of bitwise XOR.
Can you help John calculate the checksum number of today?
Input
The first line of input contains an integer
T
indicating the total number of test cases.
The first line of each test case is an integer n , indicating the number of chips produced today. The next line has n integers s1,s2,..,sn , separated with single space, indicating serial number of each chip.
1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100
The first line of each test case is an integer n , indicating the number of chips produced today. The next line has n integers s1,s2,..,sn , separated with single space, indicating serial number of each chip.
1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100
Output
For each test case, please output an integer indicating the checksum number in a line.
Sample Input
2 3 1 2 3 3 100 200 300
Sample Output
6 400
Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)
听说暴力也可以过。。。字典树都用了3073ms。。
听说暴力也可以过。。。字典树都用了3073ms。。
#include<iostream>
using namespace std;
#include<stdio.h>
#include<vector>
#include<map>
#include<math.h>
#include<queue>
#include<string.h>
#define MS(a,b) memset(a,b,sizeof(a))
#include<algorithm>
const int N=500000;
int ch[N][2],sz,val[N],num[N];
void Insert(int x)
{
int u=0,c=0,i;
for(i=31;i>=0;i--)
{
c=(x>>i)&1;//本来i从32开始减的,c会计算错,(9>>32)&1会算成1。。。无语
if(!ch[u][c])
ch[u][c]=sz++;
u=ch[u][c];
val[u]++;
}
num[u]=x;
}
void Delete(int x)
{
int u=0,c,i;
for(i=31;i>=0;i--)
{
c=(x>>i)&1;
u=ch[u][c];
val[u]--;
}
}
int Query(int x)
{
int u=0,c,i;
for(i=31;i>=0;i--)
{
c=(x>>i)&1;
if(ch[u][!c]&&val[ch[u][!c]])
u=ch[u][!c];
else u=ch[u][c];
}
return x^num[u];
}
int main()
{
/*freopen("in.txt","r",stdin);
freopen("out.txt","w",stdout);*/
int t,n,s[1050],i,j,ans;
scanf("%d",&t);
while(t--)
{ MS(val,0);MS(ch,0);sz=1;
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&s[i]);
for(i=0;i<n;i++)
Insert(s[i]);
ans=-1;
for(i=0;i<n;i++)
{
Delete(s[i]);
for(j=i+1;j<n;j++)
{
Delete(s[j]);
int y=Query(s[i]+s[j]);
if(ans<y)
ans=y;
Insert(s[j]);
}
Insert(s[i]);
}
printf("%d\n",ans);
}
return 0;
}