1626 - Brackets sequence

Let us define a regular brackets sequence in the following way:

Empty sequence is a regular sequence.
If S is a regular sequence, then (S) and [S] are both regular sequences.
If A and B are regular sequences, then AB is a regular sequence.
For example, all of the following sequences of characters are regular brackets sequences:

(), [], (()), ([]), ()[], ()[()]

And all of the following character sequences are not:

(, [, ), )(, ([)], ([(]

Some sequence of characters ‘(‘, ‘)’, ‘[‘, and ‘]’ is given. You are to find the shortest possible regular brackets sequence, that contains the given character sequence as a subsequence. Here, a string a1a2…an is called a subsequence of the string b1b2…bm, if there exist such indices 1 ≤ i1 < i2 < … < in ≤ m, that aj=bij for all 1 ≤ j ≤ n.

Input

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed by a blank line, and there is also a blank line between two consecutive inputs.
The input file contains at most 100 brackets (characters ‘(‘, ‘)’, ‘[’ and ‘]’) that are situated on a single line without any other characters among them.

Output

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.
Write to the output file a single line that contains some regular brackets sequence that has the minimal possible length and contains the given sequence as a subsequence.

Sample Input

1

([(]
Sample Output

()[()]

题目描述 Description
定义满足以下规则字符串为规则序列,否则不是规则序列:

1.空序列是规则序列;

2.如果S是规则序列,那么(S),[S],{S}和也是规则序列;

3.如果A和B都是规则序列,那么AB也是规则序列。

例如,下面的字符串都是规则序列:

(),[],(()),([]),()[],()[()],{{}}<>,([]<>{{}}),<<{}>>

而以下几个则不是:

(,[,],)(,()),([(),<<,{(}),<{}>)

现在,给你一些由”(“、”)”、”[“、”]”、”{“、”}”、”<”、”>”构成的字符串,请判断该字符串最少添加多少括号成为规则序列,输出填充后的括号序列。若有多解随意输出一个。

Sample Input

1

([(]
Sample Output

()[()]

我有话说:
这道题的基本思路是采取动态规划。
策略是:
设d[i,j]代表对应字符串下标修改成正规括号序列所需最少填充的括号数。
1.如果S[i],S[j]对应的是一对括号(){}。那么显然S[i][j]=S[i+1][j-1];
2.如果不是的话。那么如划分型DP的基本策略枚举k是i,j的中间一个坐标。那么S[i][j]=S[i][k]+S[k+1][j];
3.不管1成不成立也都要运行2的操作。因为如”[][]”的序列也是会被判为非法的。其实它压根不需要处理。

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=100+10;
char S[maxn];
int d[maxn][maxn],n;//d数组表示区间[i,j]内最少需填的括号数
void readline(char* S)
{
    fgets(S,maxn,stdin);
}
bool match(char a,char b)
{
    if(a=='['&&b==']')return true;
    if(a=='('&&b==')')return true;
    return false;
}
void print(int i,int j)
{
    if(i>j)return;
    if(i==j){
        if(S[i]=='['||S[i]==']')printf("[]");
        else printf("()");
        return;
    }
    if(match(S[i],S[j])&&d[i][j]==d[i+1][j-1])
    {
        printf("%c",S[i]);print(i+1,j-1);printf("%c",S[j]);
        return;
    }
    for(int k=i;k<j;k++)
    {
        if(d[i][k]+d[k+1][j]==d[i][j])
        {
            print(i,k);print(k+1,j);
            return;
        }
    }
}
void dp()
{
    for(int i=0;i<n;i++)
    {
        d[i][i]=1;
        d[i+1][i]=0;//越界
    }
    for(int i=n-2;i>=0;i--)//注意枚举的顺序。
    {
        for(int j=i+1;j<n;j++)
        {
            d[i][j]=n;
            if(match(S[i],S[j]))
            {
                d[i][j]=min(d[i][j],d[i+1][j-1]);
            }
                for(int k=i;k<j;k++)
                {
                    d[i][j]=min(d[i][j],d[i][k]+d[k+1][j]);
                }

        }
    }
    //printf("%d\n",d[0][n-1]);
    print(0,n-1);
}
int main()
{
    int T;
    readline(S);//其实这道题目有一个陷阱。就是可能输入的是空串。所以不能用scanf;
    sscanf(S,"%d",&T);
    readline(S);//这个是格式问题请注意样例1下面有一空行
    while(T--)
    {
        readline(S);
        memset(d,0,sizeof(d));
        n=strlen(S)-1;
        dp();
        printf("\n");
        if(T) printf("\n");
        readline(S);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值