hdu3183 一道欲哭无泪的题

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=3183

A Magic Lamp

                    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                    Total Submission(s): 2930    Accepted Submission(s): 1143


 Problem Description
Kiki likes traveling. One day she finds a magic lamp, unfortunately the genie in the lamp is not so kind. Kiki must answer a question, and then the genie will realize one of her dreams. 
The question is: give you an integer, you are allowed to delete exactly m digits. The left digits will form a new integer. You should make it minimum.
You are not allowed to change the order of the digits. Now can you help Kiki to realize her dream?
 

Input
There are several test cases.
Each test case will contain an integer you are given (which may at most contains 1000 digits.) and the integer m (if the integer contains n digits, m will not bigger then n). The given integer will not contain leading zero.
 

Output
For each case, output the minimum result you can get in one line.
If the result contains leading zero, ignore it. 
 

Sample Input
  
  
178543 4 1000001 1 100001 2 12345 2 54321 2
 

Sample Output
  
  
13 1 0 123 321

之前一直想的是每次删除最大的数,直到够n个,后来才发现对于31452 2是错误的

想了好长时间才知道,可以找在范围内找最小

正确代码

#include<stdio.h>
int main()
{
    char a[1100];
    int n,len,i,j,flag,sum,min,k,flag1;
    while(scanf("%s%d",a,&n)!=EOF)
    {
        len=0;
        for(i=0; a[i]!='\0'; i++)
            len++;
        flag=0;
        k=0;
        for(i=len-n; i>0; i--)//这是删除n个后剩下的数
        {
            min=10;
            for(j=k; j<len-i+1; j++)//从0~m,min1~m+1...minn~m+n范围内找出最小的数
            {
               // printf("%c ",a[j]);
                if(min>a[j]-'0')
                {
                    min=a[j]-'0';
                    flag1=j+1;
                }
            }
             if(min!=0)
                    flag=1;
                if(flag==0&&min==0) ;//判断前导是0的情况
                else
                    printf("%d",min);
                k=flag1;
        }
        if(flag==0)//标记是否全部为0;
            printf("0");
        printf("\n");


    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值