A-1001

题目内容:

1001. A+B Format (20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991
 
 
思路:
计算两个整数的和,然后新建一个数组用来储存每个数字的字符形式,因为使用了取余相除的方法计算,每隔三个存储位数字,另存一个逗号。
 
 
代码:
#include<stdio.h>
int main()
{
    long long a,b,c;
    int count=0,i=0,j=0;
    char num[20];
    scanf("%lld%lld",&a,&b);
    c=a+b;
    if(c<0)
    {
        printf("-");
        c=(-1)*c;
    }
    do
    {
        if(count%3==0&&count!=0)
        {
            num[i++]=',';
        }
        num[i++]=c%10+'0';
        count++;
        c/=10;
    }while(c!=0);
    for(j=i-1;j>=0;j--)
        printf("%c",num[j]);
return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值