数据结构实验之二叉树的建立与遍历

数据结构实验之二叉树的建立与遍历

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
       已知一个按先序序列输入的字符序列,如abc,,de,g,,f,,,(其中逗号表示空节点)。请建立二叉树并按中序和后序方式遍历二叉树,最后求出叶子节点个数和二叉树深度。

Input
  输入一个长度小于50个字符的字符串。
Output
输出共有4行:
第1行输出中序遍历序列;
第2行输出后序遍历序列;
第3行输出叶子节点个数;
第4行输出二叉树深度。
Example Input
abc,,de,g,,f,,,
Example Output
cbegdfa
cgefdba
3
5
 
 
#include <stdio.h>
#include <stdlib.h>

int i,cnt;
typedef struct node
{
    char data;
    struct node *l,*r;
}node;

node *create(char *str)
{
    node *root;
    if(str[i]==','){
        i++;
        root = NULL;
    }
    else{
        root = (node *)malloc(sizeof(struct node));
        root->data = str[i++];
        root->l = create(str);
        root->r = create(str);
    }
    return root;
}

void *inOrder(node *root)
{
    if(root){
        inOrder(root->l);
        printf("%c",root->data);
        inOrder(root->r);
    }
}

void *postOrder(node *root)
{
    if(root){
        postOrder(root->l);
        postOrder(root->r);
        printf("%c",root->data);
    }
}

int *leavesPrint(node *root)
{
    if(root){
        if(root->l==NULL&&root->r==NULL)
            cnt++;
        leavesPrint(root->l);
        leavesPrint(root->r);
    }
    return cnt;
}

int *depth(node *root)
{
    int d = 1;
    if(root){
        int dl = depth(root->l);
        int dr = depth(root->r);
        d = dl>dr?dl+1:dr+1;
    }
    else
        return 0;
    return d;
}

int main()
{
    char str[100];
    cnt = 0;
    scanf("%s",str);
    node *root = create(str);
    inOrder(root);
    printf("\n");
    postOrder(root);
    printf("\n");
    printf("%d\n",leavesPrint(root));
    printf("%d\n",depth(root));
    return 0;
}

这题就是各种方法的集合罢了,其他基本的掌握了,这个也不难,说实话二叉树在这个程度上并不算难。
这次没用MarkDown编辑器,感觉怪不舒服的,如果用的话,这个题目描述的字体格式和颜色又都不行了,真是麻烦啊,哪位高人知道如何处理的啊??
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值