zcmu-1039 二哥的困惑Ⅱ

【题述】

Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture: 

Every even number greater than 4 can be 

written as the sum of two odd prime numbers. 

For example: 

8 = 3 + 5. Both 3 and 5 are odd prime numbers. 

20 = 3 + 17 = 7 + 13. 

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23. 

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.) 

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million. 

Input

The input will contain one or more test cases. 

Each test case consists of one even integer n with 6 <= n < 1000000. 

Input will be terminated by a value of 0 for n. 

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong." 

Sample Input

8 20 42 0

Sample Output

8 = 3 + 5 20 = 3 + 17 42 = 5 + 37

题意:

   水题。

    多组输入,证实:每个大于4的偶数n,都可以表示为两个奇素数之和(6<=n<1000000),输入0终止程序;

    输入n,输出n=a+b,(选择b-a差最大的一组打印),如果不存在ab使得n=a+b,输出Goldbach's conjecture is wrong.(不会出现这种情况所以不用考虑)

 

【我的代码(通过代码)】

#include <iostream>

#include <cmath>

using namespace std;

bool is_prime(int n){

    int j;

    for(j=2;j<=sqrt(n);j++){

        if(n%j==0){

            return 0;

            break;

        }

    }

    return 1;

}

int main(int argc, const char * argv[]) {

    int n,i;

    while(cin>>n){

        if(n==0)

            break;

        for(i=2;i<n;i++){

            if(is_prime(i)&&is_prime(n-i)){//选择b-a差最大的一组打印(最关键的一行)

                cout<<n<<" = "<<i<<" + "<<n-i<<endl;

                break;

            }

        }

    }

   

    return 0;

}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值