pat-1001 A+B Format (20)

 

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991

 

 题意:

  输出a+b,每三位用逗号分隔

思路:

  没什么难点,很多方法都可以做,这里我用一个比较简单的方法。

#include <string>
#include <iostream>
#include <sstream>
#include <cstdlib>
#include <cstdio>
using namespace std;
int main(){
    long a,b,c,i;
    while(cin>>a>>b){
        c=a+b;
        string str;
        str=to_string(c);//int 转换为string 类型

        size_t  len=str.length();
        if(c<0&&(len-1)%3==0){//这里考虑特殊情况,如:-100,000,负号后不用输出逗号
            for(i=(int)len-3;i>1;i-=3){//注意要从低位开始循环
                str.insert(i,",");
            }
        }
        else if(len%3==0){//这里考虑特殊情况,如100,000,最前面不用输出逗号
            for(i=(int)len-3;i>1;i-=3){
                str.insert(i,",");
            }
        }
        else{
            for(i=(int)len-3;i>0;i-=3){//这里考虑普通情况
                str.insert(i,",");
            }
        }

        cout<<str<<endl;
    }




    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值