zcmu-4952: 姓名排序(字符字典序排序)

 

Time Limit: 1 Sec  Memory Limit: 32 MB
Submit: 7  Solved: 7
[Submit][Status][Web Board]

Description

存储一组姓名,如Apple,Tom,Green,Jack 要求按照字典序排序并显示。

Input

输入第一行为样例数m,对于每个样例,第一行为人数n,接下来有n个姓名,n不超过10,每个名字长度不超过20。

Output

对于每个样例输出排序后的结果,每行一个姓名。

Sample Input

1 4 Apple Tom Green Jack

Sample Output

Apple Green Jack Tom

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
string a[20];
bool cmp(string a,string b)
{
    return a < b ;
}
int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i = 0 ; i < n ; i ++)
            cin>>a[i];
        sort(a,a + n,cmp);
        for(int i = 0 ; i < n;i++)
            cout<<a[i]<<endl;
    }
    return 0;
}

 

  • 2
    点赞
  • 5
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值