【PAT天梯赛】L1-023 输出GPLT(20 分)(思维)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“GPLTGPLT....”这样的顺序输出,并忽略其它字符。当然,四种字符(不区分大小写)的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按GPLT的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt
输出样例:

GPLTGPLTGLTGLGLL
--------------------- 
作者:天涯with0 
来源:CSDN 
原文:https://blog.csdn.net/weixin_42173193/article/details/80757950 
版权声明:本文为博主原创文章,转载请附上博文链接!

 

这道题做好几遍了,每次都会有地方错!! (学习自博客链接

#include<cstdio>
#include<iostream>
#include <algorithm>
#include<cstring>
#include<sstream>
#include <cmath>
#include <set>
#include<map>
#include <vector>
#define ll long long
using namespace std;
const int N = 1e4+5;
char strs[N];
int gplt[4];
int main()
{
    scanf("%s",strs);
    for(int i=0;i<strlen(strs);i++)
    {
        if(strs[i]=='g'||strs[i]=='G')
        {
            gplt[0]++;
        }
        else if(strs[i]=='p'||strs[i]=='P')
        {
            gplt[1]++;
        }
        else if(strs[i]=='L'||strs[i]=='l')
        {
            gplt[2]++;
        }
        else if(strs[i]=='t'||strs[i]=='T')
        {
            gplt[3]++;
        }
    }
    while(gplt[0]>0||gplt[1]>0||gplt[2]>0||gplt[3]>0)
    {
        for(int i=0;i<4;i++)
        {
            if(gplt[i]>0)
            {
                switch(i)
                {
                    case 0:
                        putchar('G');
                        break;
                    case 1:
                        putchar('P');
                        break;
                    case 2:
                        putchar('L');
                        break;
                    case 3:
                        putchar('T');
                        break;
                        
                }
                gplt[i]--;
            }
        }
    }
    
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值