c++实验6-A(1829)新奇的加法运算

 Problem A: 新奇的加法运算

Time Limit: 1 Sec  Memory Limit: 128 MB
Submit: 5615  Solved: 3690
[Submit][Status]

Description

定义类newInt,包括:

1. int类型的数据成员。

2. 重载运算符“+”。计算规则为:将A、B对应位置上的数字相加,只保留个位数作为结果的对应位置上的数字。比如:876 + 543 = 319。注意:该运算不改变两个操作数的值。

3. 重载输入和输出运算符,用于输入和输出对象的属性值。

4. 无参构造函数和带参构造函数。

Input

第1行N>0,表示测试用例数量。

每个测试用例包括2个非负整数,用空格隔开。

Output

见样例。

Sample Input

4 876 543 999 9999 9 1999 199 88

Sample Output

876 + 543 = 319 999 + 9999 = 9888 9 + 1999 = 1998 199 + 88 = 177

HINT

 不能使用string、char等字符或字符串类型。

Append Code

append.cc,


int main()
{
    int cases;
    newInt a, b, c;
    cin>>cases;
    for (int i = 0; i < cases; i++)
    {
        cin>>a>>b;
        c = a + b;
        cout<<a<<" + "<<b<<" = "<<c<<endl;
    }
    return 0;
}

答案:

#include<iostream>
#include<math.h>
using namespace std;
class newInt
{
private:
    int x;
public:
    newInt():x(0){}
    newInt(int xx):x(xx){}
  friend int operator+(const newInt& a, const newInt& b)
   {
       int c=a.x,d=b.x,m,n,s=0,i=0;
       while(c!=0||d!=0)
       {
          double t=pow(10,i);
           m=c%10;
           n=d%10;
           s=s+(m+n)%10*t;
           c=c/10;
           d=d/10;
           ++i;
       }
       return s;
   }
   friend ostream &operator <<(ostream &os,newInt &t)
    {
        os<<t.x;
        return os;
    }
    friend istream &operator >>(istream &is,newInt &t)
    {
        is>>t.x;
        return is;
    }
};

int main()
{
    int cases;
    newInt a, b, c;
    cin>>cases;
    for (int i = 0; i < cases; i++)
    {
        cin>>a>>b;
        c = a + b;
        cout<<a<<" + "<<b<<" = "<<c<<endl;
    }
    return 0;
}

分析:

不能用字符串,字符数组和字符指针

考虑类属性用整型数组,但因类的属性定义为整型数组时不好进行从右开始的各位相加,若类属性不用数组,将各位和存入数组并返回的话,运算符重载返回整型数与main函数中c的类型矛盾,综上所述,不用整型数组。

通过乘10的次方将得到的各位数和化为一个整数并返回int型,或将得到的整数赋值给类对象c的属性c.x,返回类对象c

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值