HDU2051 Bitset

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 21100    Accepted Submission(s): 15644


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

Input
For each case there is a postive number n on base ten, end of file.
 

Output
For each case output a number on base two.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 10 11


#include <stdio.h>

int a[1005][10];

int main(){

	int i,j,n;
	
	for(i = 1; i <= 1000; i ++)
	{
		j = 10;
		int temp = i;
		
		while(temp){
			a[i][j --] = temp % 2;
			temp /= 2;
		}
	}
	
	while(scanf("%d",&n) != EOF){
		int flag = 0;
		for(j = 1; j <= 10; j ++){
			if(a[n][j])
				flag = 1;
			
			if(flag)
				printf("%d",a[n][j]);
		}
		putchar('\n');
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值