HDU1059 Dividing (多重背包)

12 篇文章 0 订阅

Dividing

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24952    Accepted Submission(s): 7116


Problem Description
Marsha and Bill own a collection of marbles. They want to split the collection among themselves so that both receive an equal share of the marbles. This would be easy if all the marbles had the same value, because then they could just split the collection in half. But unfortunately, some of the marbles are larger, or more beautiful than others. So, Marsha and Bill start by assigning a value, a natural number between one and six, to each marble. Now they want to divide the marbles so that each of them gets the same total value. 
Unfortunately, they realize that it might be impossible to divide the marbles in this way (even if the total value of all marbles is even). For example, if there are one marble of value 1, one of value 3 and two of value 4, then they cannot be split into sets of equal value. So, they ask you to write a program that checks whether there is a fair partition of the marbles.
 

Input
Each line in the input describes one collection of marbles to be divided. The lines consist of six non-negative integers n1, n2, ..., n6, where ni is the number of marbles of value i. So, the example from above would be described by the input-line ``1 0 1 2 0 0''. The maximum total number of marbles will be 20000. 

The last line of the input file will be ``0 0 0 0 0 0''; do not process this line.
 

Output
For each colletcion, output ``Collection #k:'', where k is the number of the test case, and then either ``Can be divided.'' or ``Can't be divided.''. 

Output a blank line after each test case.
 

Sample Input
  
  
1 0 1 2 0 0 1 0 0 0 1 1 0 0 0 0 0 0
 

Sample Output
  
  
Collection #1: Can't be divided. Collection #2: Can be divided.
 

Source
 

【题目要求:】求是否能够把收藏的物品正好平均分。

【思路:】有6种物品,每个物品的个数是一定的,从这些条件分析来看符合多重背包的要求,这时有的人可能会有疑惑了,如果要是背包问题,那背包的容量怎么确定?别急,接着往下看。因为要按照价值平均分,所以只有当价值是偶数的时候才能够平均分,假设总价值为sum,平均分则要每个人的价值为sum / 2,即只要有一个人分的sum/2的价值的物品即可,所以背包的容量为sum/2,问题就转化成恰好装满容量为sum/2的多重背包问题。


#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

int aver,a[10],dp[120005]; 

void ZeroOnePack(int cost, int weight){
	for(int i = aver; i >= cost; i --)
		dp[i] = max(dp[i],dp[i - cost] + weight);
}

void CompletePack(int cost, int weight){
	for(int i = cost; i <= aver; i ++)
		dp[i] = max(dp[i],dp[i - cost] + weight);
}

void MultiplePack(int cost, int weight, int amount){
	if(amount * cost >= aver){
		CompletePack(cost,weight);
		return ;
	}
	
	for(int k = 1; k < amount; k *= 2){
		ZeroOnePack(k * cost, k * weight);
		amount -= k;
	}
	ZeroOnePack(amount * cost, amount * weight);
}

int main(){
	int ans = 0;
	
	while(1){
		int sum = 0;
		for(int i = 1; i <= 6; i ++){
			cin >> a[i];
			sum += a[i] * i;
		}
		
		if(!sum)
			break;
	
		if(sum % 2){
			printf("Collection #%d:\n",++ans);
			printf("Can't be divided.\n\n");
			continue;
		}
	
		aver = sum / 2;
		memset(dp,0,sizeof(dp));	
		for(int i = 1; i <= 6; i ++){
			MultiplePack(i,i,a[i]);
		}
	
		printf("Collection #%d:\n",++ans);
		if(dp[aver] == aver)
			printf("Can be divided.\n\n");
		else
			printf("Can't be divided.\n\n");
	}	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值