HDU1016 Prime Ring Problem (DFS)

23 篇文章 0 订阅

Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46702    Accepted Submission(s): 20639


Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.


 

Input
n (0 < n < 20).
 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

Sample Input
  
  
6 8
 

Sample Output
  
  
Case 1: 1 4 3 2 5 6 1 6 5 2 3 4 Case 2: 1 2 3 8 5 6 7 4 1 2 5 8 3 4 7 6 1 4 7 6 5 8 3 2 1 6 7 4 3 8 5 2
 

Source
 

思路:对每个数进行访问标记,一道简单的DFS题目、

#include <stdio.h>
#include <string.h>
int f[45],ans = 1,vis[25];
void dfs(int cur, int n, int a[]){
	
	if(cur == n && !f[a[cur] + a[1]]){
		for(int i = 1; i <= n; i ++){
			if(i > 1)
				putchar(' ');
			printf("%d",a[i]);
		}
		putchar('\n');
	}
	
	for(int i = 2; i <= n; i ++){
	if(cur < n && !vis[i]){
			if(!f[i + a[cur]]){
				a[cur + 1] = i;
				vis[i] = 1;
				dfs(cur+1,n,a);
				vis[i] = 0;
			}
		}	
	}
}

int main(){
	int n,a[25];
	
	f[0] = f[1] = 1;
	for(int i = 2; i <= 40; i ++){
		int flag = 1;
		for(int j = 2; j <= i / 2; j ++){
			if(i % j == 0){
				flag = 0;
				break;
			}
		}
		if(!flag)
			f[i]  = 1;
	}
	
	while(~scanf("%d",&n)){
		memset(a,0,sizeof(a));
		memset(vis,0,sizeof(vis));
		vis[1] = 1; a[1] = 1;
		printf("Case %d:\n",ans++);
		dfs(1,n,a);
		putchar('\n');
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值