POJ2488 A Knight's Journey (DFS)

23 篇文章 0 订阅

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 43581 Accepted: 14821

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany


思路,在做本题的时候要注意输出的路径是按照字典序由小到大的顺序输出的,所以在搜索的时候的方向要注意,也就是dir[]要注意元素的安排,应从左到右,从上到下。


#include <cstdio>
#include <cstring>
using namespace std;

int t,p,q,vis[30][30],b[30],cas,dir[8][2] = {-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1},flag,k;
char a[30],c[30];
void dfs(int x, int y, int cur,int k){
	int sx,sy;
	if(cur == p * q){
		flag = 1;
		for(int i = 0; i < k; i ++){
			printf("%c%d",a[i],b[i]);
		}
		printf("\n");
		return;
	}
	if(flag)
		return;
	
	for(int i = 0; i < 8; i ++){
		sx = x + dir[i][1];
		sy = y + dir[i][0];
		
		if(sx > 0 && sx <= p && sy > 0 && sy <= q && !vis[sx][sy]){
			vis[sx][sy] = 1;
			a[k] = c[sy];
			b[k] = sx;
			dfs(sx,sy,cur+1,k+1);
			vis[sx][sy] = 0;
		}
	}
}

int main(){
	scanf("%d",&t);
	char ch = 'A';
	while(ch <= 'Z'){
		c[++ k] = ch;
		ch ++;
	}
	
	while(t --){
		scanf("%d%d",&p,&q);
		flag = 0; k = 0;
		memset(vis,0,sizeof(vis));
		printf("Scenario #%d:\n",++cas);
		for(int i = 1; i <= p; i ++){
			for(int j = 1; j <= q; j ++){
				vis[i][j] = 1;
				a[k] = c[j];
				b[k] = i;
				dfs(i,j,1,k+1);
				vis[i][j] = 0;
			}
		}
		if(!flag)
			printf("impossible\n");
		printf("\n");
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值