POJ1751 Highways

Highways
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14720 Accepted: 4254 Special Judge

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 

Input

The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 

Output

Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 

Sample Input

9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2

Sample Output

1 6
3 7
4 9
5 7
8 3

Source



思路:题意很简单,就是在已经存在的高铁的基础上,在增修其他的高铁,使得任意两个城镇之间都可以到达。在做本题的时候要先明白,一共有n个城镇,m个已经存在的高铁,m<=1000,n<=750,所以m的值有可能大于n,也就是说已经存在的高铁有可能使得任意两个城镇间都能够到达。所以在一开始就要判断是否存在满足条件的已经修好的铁路。如果已经存在的高铁不能够使得任意两个城镇之间到达,则必须要再增修其他高铁使得两城镇能够互达。首先求出任意两个城镇之间的距离,对这些距离进行排序,利用克鲁斯卡尔算法求解最小生成树即可。详细代码如下:


#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

int n,m,ans,par[1005],rank[1005];
struct node{
	int x,y;
}point[1005];
struct Dis{//存储任意两城镇的距离,并记录城镇号 
	int x,y;
	double distance;
}dis[350000];

bool cmp(Dis A, Dis B){
	return A.distance < B.distance;
}

int find(int x){
	if(x == par[x])
		return x;
	return par[x] = find(par[x]);
}

int UnoinSet(int u, int v){
	int x = find(u);
	int y = find(v);
	if(x != y){
		if(rank[x] > rank[y])
			par[y] = x;
		else{
			par[x] = y;
			if(rank[x] == rank[y])
				rank[y] ++;
		}
		return 1;
	}
	return 0;
}

double Distance(int x1, int y1, int x2, int y2){
	return sqrt((x1-x2)*(x1-x2) + (y1-y2)*(y1-y2));
}

int main(){
	ans = 0;
	scanf("%d",&n);
	for(int i = 1; i <= n; i ++){//初始化 
		par[i] = i;
		rank[i] = 0;
	}
	for(int i = 1; i <= n; i ++){
		scanf("%d%d",&point[i].x,&point[i].y);
	}
	scanf("%d",&m);
	for(int i = 1; i <= m; i ++){//判断已存在的高铁连接的城镇 
		int u,v;
		scanf("%d%d",&u,&v);
		int index = UnoinSet(u,v);
		if(index)
			ans ++;
	}
	
	int k = 0;
	for(int i = 1; i <= n; i ++){//求任意两城镇之间的距离 
		for(int j = i+1; j <= n; j ++){
			dis[k].x = i; dis[k].y = j;
			dis[k ++].distance = Distance(point[i].x,point[i].y,point[j].x,point[j].y);
		}
	}
	sort(dis,dis+k,cmp);//对城镇之间的距离进行从小到大的排序 

	for(int i = 0; i < k; i ++){
		if(ans >= n-1)//判断是否最小生成树中是否存在n-1条边 
			break;
		int index = UnoinSet(dis[i].x,dis[i].y);
		if(index){
			printf("%d %d\n",dis[i].x,dis[i].y);//输出要添加的边 
			ans ++;
		}
	} 
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值