HDU1150 Machine Schedule(最小顶点覆盖)

Machine Schedule

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8927    Accepted Submission(s): 4483


Problem Description
As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem.

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, …, mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, … , mode_m-1. At the beginning they are both work at mode_0.

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y.

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 
 

Input
The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y.

The input will be terminated by a line containing a single zero.
 

Output
The output should be one integer per line, which means the minimal times of restarting machine.
 

Sample Input
  
  
5 5 10 0 1 1 1 1 2 2 1 3 3 1 4 4 2 1 5 2 2 6 2 3 7 2 4 8 3 3 9 4 3 0
 

Sample Output
  
  
3
 

Source
 

题意:有A和B两种机器,A机器有n种模式,B机器有m种模式,有k种工作,每次执行工作都是A或者B中的模式,每次改变模式都要重新启动,求得是重新启动的最少次数。

思路:假设job i,则i要选择A机器或者B机器的某种模式,把当前A机器和B机器之间用一条边连接起来,则在A和B之间一共存在k条边,所以可能存在某种模式上有多条边,也就是某种模式可能会执行多个job,所以这个问题就转化成求最小顶点覆盖数的问题了,最小顶点覆盖数=最大匹配数。

#include <cstdio>
#include <cstring>
using namespace std;

int n,m,k,link[105],vis[105],a[105][105];

int find(int x){
	for(int i = 1; i < m; i ++){ 
		if(!vis[i] && a[x][i]){//当前模式在本次查找中没有被访问过并且两者之间存在关系 
			vis[i] = 1;
			if(link[i] == -1 || find(link[i])){//该模式没有被匹配过或者原来匹配的对象可以再换个 
				link[i] = x;
				return 1;
			}
		}
	}
	return 0;
}

int main(){
	while(~scanf("%d",&n) && n){
		memset(link,-1,sizeof(link));
		memset(a,0,sizeof(a)); 
		scanf("%d%d",&m,&k);
		for(int i = 0; i < k; i ++){
			int x,y,z;
			scanf("%d%d%d",&x,&y,&z);
			if(y && z)  //两台机器的初始化模式为0 
				a[y][z] = 1;
		}
		int cnt = 0;
		for(int i = 1; i < n; i ++){//查找其余n-1个模式 
			memset(vis,0,sizeof(vis));
			if(find(i))
				cnt ++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值