HDU1398 Square Coins(母函数)

 

Square Coins

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12100    Accepted Submission(s): 8289

 

 

Problem Description

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland. 
There are four combinations of coins to pay ten credits: 

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin. 

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

 

 

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

 

 

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output. 

 

 

Sample Input

 

2 10 30 0

 

 

Sample Output

 

1 4 27

 

 

Source

Asia 1999, Kyoto (Japan)

 

 

 

 

 

根据题意可以构造出该题的母函数,G(x)=(1+x+x^2+x^3+......) +(1+x^2+x^4+x^8+.....)+......,所以根据G(x)这个式子求解即可

 

AC代码:

 

#include <cstdio>
#include <cstring>
using namespace std;

int c1[305],c2[305],n;//k * c1[n]表示幂指数为n的系数为k 
//也就是表示n个coins的方式为k种
int main(){
	while(~scanf("%d",&n) && n){
		for(int i = 0; i <= n; i ++){//c1[]表示对第一个表达式进行初始化 ,一个()里的内容代表一个表达式 
			c1[i] = 1;
			c2[i] = 0;
		}
		
		for(int i = 2; i <= 17; i ++){//从第二个表达式开始计算 
			for(int j = 0; j <= n; j ++){//取该表达式里第j个元素 
				for(int k = 0; k+j <= n; k += i*i){//下个表达式每个元素之间的增量是i*i; 
					c2[k+j] += c1[j];//c2[k+j] = c2[k+j] + c1[j] * c2[k],	其中c2[k]=1就类似于合并同类项 
				}
			}
			for(int j = 0; j <= n; j ++){//更新c1[]的值 
				c1[j] = c2[j];
				c2[j] = 0;
			} 
		}
		printf("%d\n",c1[n]);
	}
	return 0;
} 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值