HDU1525 Euclid's Game (找规律博弈)

33 篇文章 1 订阅
24 篇文章 0 订阅

Euclid's Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3434    Accepted Submission(s): 1599


Problem Description
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7): 

25 7
11 7
4 7
4 3
1 3
1 0 

an Stan wins. 

 

Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
 

Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed. 

 

Sample Input
  
  
34 12 15 24 0 0
 

Sample Output
  
  
Stan wins Ollie wins
 

Source
 


思路:题目让求的是用大的数减去小的数,能够使得其中的一个数变成0的人为胜者。首先来分析下,假设a>=b,如果a==b 或者a%b==0则先手为胜,当a>=2*b时,则可以判断(a%b,b)是必胜点或者必败点,如果是必败点则可以走到这点,如果是必胜点则可以走到(a%b+b,b),当a < 2*b,则可以通过 a-=b计算


#include <cstdio>
#include <algorithm>
using namespace std;

int a,b;

int main(){
	while(~scanf("%d%d",&a,&b)){
		if(a==0&&b==0)
			break;
		if(a < b)
			swap(a,b);
		int flag = 0;
		while(b){
			if(a%b == 0 || a / b >= 2)
				break;
			a -= b;
			swap(a,b);
			flag = !flag;
		}
		if(flag)
			printf("Ollie wins\n");
		else
			printf("Stan wins\n");
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值