HDU4991 Ordered Subsequence (树状数组+dp)

Ordered Subsequence

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 674    Accepted Submission(s): 319


Problem Description
A numeric sequence of a i is ordered if a 1<a 2<……<a N. Let the subsequence of the given numeric sequence (a 1, a 2,……, a N) be any sequence (a i1, a i2,……, a iK), where 1<=i 1<i 2 <……<i K<=N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, eg. (1, 7), (3, 4, 8) and many others. 

Your program, when given the numeric sequence, must find the number of its ordered subsequence with exact m numbers.
 

Input
Multi test cases. Each case contain two lines. The first line contains two integers n and m, n is the length of the sequence and m represent the size of the subsequence you need to find. The second line contains the elements of sequence - n integers in the range from 0 to 987654321 each.
Process to the end of file.
[Technical Specification]
1<=n<=10000
1<=m<=100
 

Output
For each case, output answer % 123456789.
 

Sample Input
  
  
3 2 1 1 2 7 3 1 7 3 5 9 4 8
 

Sample Output
  
  
2 12
 

Source


题意:求长度为m的上升(严格上升)子序列的个数。
思路:dp[i][j]表示到第i个数字,长度为j的个数。

代码如下:
#include <bits/stdc++.h>
#define LL long long
using namespace std;

const int mod = 123456789;
const int maxn = 1e4 + 5;
int n,m,a[maxn],b[maxn],dp[maxn][105];

int lowbit(int k){
	return k & -k;
}

void update(int x, int y, int num){
	while(x <= n){
		dp[x][y] = (dp[x][y] + num) % mod;
		x += lowbit(x);
	}
}

int query(int x, int y){
	int sum = 0;
	while(x){
		sum = (sum + dp[x][y]) % mod;
		x -= lowbit(x);
	}
	return sum;
}

int main(){
	while(~scanf("%d%d",&n,&m)){
		for(int i = 1; i <= n; i ++){
			scanf("%d",&a[i]);
			b[i] = a[i];
		}
		sort(b+1,b+n+1);
		for(int i = 1; i <= n; i ++){
			a[i] = lower_bound(b+1,b+n+1,a[i]) - b;
		}
		memset(dp,0,sizeof(dp));
		for(int i = 1; i <= n; i ++){
			for(int j = 1; j <= min(i,m); j ++){
				if(j == 1) update(a[i],j,1);
				else{
					int ans = query(a[i]-1,j-1); 
					update(a[i],j,ans);
				}
			}
		}
		printf("%d\n",query(n,m));
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值