HDU6201 | 2017 ACM-ICPC 亚洲区(沈阳赛区)网络赛-H transaction transaction transaction

33 篇文章 1 订阅

transaction transaction transaction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 132768/132768 K (Java/Others)
Total Submission(s): 98    Accepted Submission(s): 42


Problem Description
Kelukin is a businessman. Every day, he travels around cities to do some business. On August 17th, in memory of a great man, citizens will read a book named "the Man Who Changed China". Of course, Kelukin wouldn't miss this chance to make money, but he doesn't have this book. So he has to choose two city to buy and sell. 
As we know, the price of this book was different in each city. It is  ai   yuan  in  i t  city. Kelukin will take taxi, whose price is  1 yuan  per km and this fare cannot be ignored.
There are  n1  roads connecting  n  cities. Kelukin can choose any city to start his travel. He want to know the maximum money he can get.
 

Input
The first line contains an integer  T  ( 1T10 ) , the number of test cases. 
For each test case:
first line contains an integer  n  ( 2n100000 ) means the number of cities;
second line contains  n  numbers, the  i th  number means the prices in  i th  city;  (1Price10000)  
then follows  n1  lines, each contains three numbers  x y  and  z  which means there exists a road between  x  and  y , the distance is  z km   (1z1000)
 

Output
For each test case, output a single number in a line: the maximum money he can get.
 

Sample Input
  
  
1 4 10 40 15 30 1 2 30 1 3 2 3 4 10
 

Sample Output
  
  
8
 

Source
 

liuyiding   |   We have carefully selected several similar problems for you:   6205  6204  6203  6202  6201 


AC代码如下:

#include <bits/stdc++.h>  
using namespace std;  
  
const int maxn = 2e5 + 10;  
struct node{  
    int x,y,cost;  
}p[maxn];  
int t,n,k,dp[maxn][2],a[maxn];  
  
int main(){  
    scanf("%d",&t);  
    while(t --){  
        scanf("%d",&n);  
        k = 0;  
        for(int i = 1; i <= n; i ++) scanf("%d",&a[i]);  
        for(int i = 1; i < n; i ++){  
            scanf("%d%d%d",&p[k].x,&p[k].y,&p[k].cost); k ++;  
            p[k].x = p[k-1].y; p[k].y = p[k-1].x; p[k].cost = p[k-1].cost; k ++;  
        }  
        memset(dp,0,sizeof(dp));  
        for(int i = 0;i < k; i ++){   
            dp[p[i].y][0] = max(dp[p[i].y][0],dp[p[i].x][0] - a[p[i].x] - p[i].cost + a[p[i].y]); 
			dp[p[i].y][1] = max(dp[p[i].y][1],dp[p[i].x][1] - a[p[i].y] - p[i].cost + a[p[i].x]);
        }  
        int mxx = dp[1][0];  
        for(int i = 1;i <= n; i ++) for(int j = 0; j < 2; j ++) mxx = max(dp[i][j],mxx); 
        printf("%d\n",mxx);  
    }  
    return 0;  
}   







  • 2
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 8
    评论
评论 8
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值