Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 21638 Accepted Submission(s): 12934
Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:
a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10 1 3 6 9 0 8 5 7 4 2
Sample Output
16
Author
CHEN, Gaoli
Source
思路:模拟一下就会发现,对于每个排列的第一个数而言,如果该数是排列中第x大的数,则在排列中存在x-1个数比该数小,存在n-x个数 比该数大,设当该数为排列的第一个元素时的逆序数为num,则当要把该数移动到排列末尾时,则当前的逆序数为 num + n - x - (x - 1),
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 5010;
int tree[maxn],a[maxn],n;
int lowbit(int k){
return k & -k;
}
void add(int num, int k){
while(k <= n){
tree[k] += num;
k += lowbit(k);
}
}
int query(int k){
int sum = 0;
while(k){
sum += tree[k];
k -= lowbit(k);
}
return sum;
}
int main(){
while(~scanf("%d",&n)){
for(int i = 1; i <= n; i ++) scanf("%d",&a[i]);
memset(tree,0,sizeof(tree));
int sum = 0;
for(int i = 1; i <= n; i ++){
a[i] ++;
sum += query(n-a[i]+1);
add(1,n-a[i]+1);
}
int ans = sum;
for(int i = 1; i <= n; i ++){
sum += n - 2 * a[i] + 1;
ans = min(sum,ans);
}
printf("%d\n",ans);
}
return 0;
}