Dropping tests
Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 14687 | Accepted: 5111 |
Description
In a certain course, you take n tests. If you get ai out of bi questions correct on test i, your cumulative average is defined to be
.
Given your test scores and a positive integer k, determine how high you can make your cumulative average if you are allowed to drop any k of your test scores.
Suppose you take 3 tests with scores of 5/5, 0/1, and 2/6. Without dropping any tests, your cumulative average is . However, if you drop the third test, your cumulative average becomes
.
Input
The input test file will contain multiple test cases, each containing exactly three lines. The first line contains two integers, 1 ≤ n ≤ 1000 and 0 ≤ k < n. The second line contains n integers indicating ai for all i. The third line contains npositive integers indicating bi for all i. It is guaranteed that 0 ≤ ai ≤ bi ≤ 1, 000, 000, 000. The end-of-file is marked by a test case with n = k = 0 and should not be processed.
Output
For each test case, write a single line with the highest cumulative average possible after dropping k of the given test scores. The average should be rounded to the nearest integer.
Sample Input
3 1
5 0 2
5 1 6
4 2
1 2 7 9
5 6 7 9
0 0
Sample Output
83
100
Hint
To avoid ambiguities due to rounding errors, the judge tests have been constructed so that all answers are at least 0.001 away from a decision boundary (i.e., you can assume that the average is never 83.4997).
Source
题目链接:http://poj.org/problem?id=2976
题意:有n个数,从中删除k个数,使得剩下的n-k个数累积的平均和最大。
思路:二分求最大平均值。
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define inf 0x3f3f3f3f
using namespace std;
const int N = 1e5 + 10;
int n,k;
double y[N];
struct node{
int x,y;
}p[N];
int judge(double x){
for(int i = 1; i <= n; i ++) y[i] = p[i].x*1.0-x*p[i].y;
sort(y+1,y+n+1);
double sum = 0;
for(int i = n; i > k; i --){
sum += y[i];
}
return sum > 0;
}
int main(){
while(~scanf("%d%d",&n,&k)){
if(n == 0 && k == 0) break;
for(int i = 1; i <= n; i ++) scanf("%d",&p[i].x);
for(int i = 1; i <= n; i ++) scanf("%d",&p[i].y);
double ub = inf, lb = 0;
for(int i = 0; i < 100; i ++){
double mid = (lb + ub) / 2;
if(judge(mid)) lb = mid;
else ub = mid;
}
printf("%.0lf\n",ub*100);
}
return 0;
}