SWERC2017 Ingredients

 

问题 E: Ingredients

时间限制: 3 Sec  内存限制: 128 MB
提交: 89  解决: 10
[提交][状态][讨论版][命题人:admin]

题目描述

The chef of a restaurant aspiring for a Michelin star wants to display a selection of her signature dishes for inspectors. For this, she has allocated a maximum budget B for the cumulated cost, and she wants to maximize the cumulated prestige of the dishes that she is showing to the inspectors.
To measure the prestige of her dishes, the chef maintains a list of recipes, along with their costs and ingredients. For each recipe, a derived dish is obtained from a base dish by adding an ingredient. The recipe mentions two extra pieces of information: the cost of applying the recipe, on top of the cost of the base dish, and the prestige the recipe adds to the prestige of the base dish. The chef measures the prestige by her own units, called “prestige units.”
For example, a recipe list for making pizza looks like:
• pizza_tomato pizza_base tomato 1 2
• pizza_classic pizza_tomato cheese 5 5
Here, pizza_base is an elementary dish, a dish with no associated recipe, a dish so simple that its cost is negligible (set to 0) and its prestige also 0. The chef can obtain the derived dish pizza_tomato by adding the ingredient tomato to the base dish pizza_base, for a cost of 1 euro and a gain of 2 prestige units. A pizza_classic is obtained from a pizza_tomato by adding cheese, for an added cost of 5, and a prestige of 5 added to the prestige of the base dish; this means the total cost of pizza_classic is 6 and its total prestige is 7.
A signature dish selection could for instance include both a pizza_tomato and a pizza_classic.
Such a selection would have cumulated total prestige of 9, and cumulated total cost of 7.
Armed with the list of recipes and a budget B, the chef wants to provide a signature dish selection to Michelin inspectors so that the cumulated total prestige of the dishes is maximized, keeping their   cumulated   total cost at most B.
Important Notes
• No dish can appear twice in the signature dish selection.
• Any dish that does not appear as a derived dish in any recipe is considered to be an elementary dish, with cost 0 and prestige 0.
• A dish can appear more than once as a resulting dish in the recipe list; if there is more than one way to obtain a dish, the one yielding the smallest total cost is always chosen; if the total costs are equal, the one yielding the highest total prestige should be chosen.
• The recipes are such that no dish D can be obtained by adding one or more ingredients to D itself.

输入

• The first line consists of the budget B, an integer.
• The second line consists of the number N of recipes, an integer.
• Each of the following N lines describes a recipe, as the following elements separated by single  spaces:    the derived dish name (a string); the base dish name (a string); the added ingredient (a string); the added price (an integer); the added prestige (an integer).
Limits
• 0≤B≤10 000;
• 0≤N≤1 000 000;
• there can be at most 10 000 different dishes (elementary or derived);
• costs and prestiges in recipes are between 1 and 10 000 (inclusive);
• strings contain at most 20 ASCII characters (letters, digits, and ’_’ only).
 

输出

The output should consist of two lines, each with a single integer. On the first line: the maximal cumulated prestige within the budget. On the second line: the minimal cumulated cost corresponding to the maximal cumulated prestige, necessarily less than or equal to the budget.

样例输入

15
6
pizza_tomato pizza_base tomato 1 2
pizza_cheese pizza_base cheese 5 10
pizza_classic pizza_tomato cheese 5 5
pizza_classic pizza_cheese tomato 1 2
pizza_salami pizza_classic salami 7 6
pizza_spicy pizza_tomato chili 3 1

样例输出

25
15

提示

 

[提交][状态]

【题意】一个人有预算为B,某酒店菜谱上有N道菜,每道菜都有一定的花费和一定的价值,其中,有的菜可能要通过其他的菜得到,因此要加上其他菜的价值和花费,如果需要添加的某种菜(相同的菜)存在超过一个,则选择花费最小的一个,当花费相同的时候,选择价值最大的一个;求在不超过预算B的前提下,能够获得的最大价值。

【思路】建图,拓扑排序跑出每个顶点需要的花费和能够获得的价值,然后跑一遍0-1背包即可。建图时通过map<>把每个字符串映射成数字顶点。

【代码如下】

#include <bits/stdc++.h>
#define ll long long
#define inf 1e18
using namespace std;

const int N = 1e6+10;
int head[N],cnt,b,n,k,deg[N];
long long a[N],c[N],dp[N];
struct Edge{
    int v,cost,value,next;
}edge[N];
char sa[210],sb[210],sc[210];
unordered_map<string,int>mp;

void add(int u, int v, int x, int y){
    edge[cnt].v = v;
    edge[cnt].next = head[u];
    edge[cnt].cost = x;
    edge[cnt].value = y;
    head[u] = cnt ++;
}

int main(){
    scanf("%d%d",&b,&n);
    memset(head,-1,sizeof(head));
    for(int i = 0; i < n; i ++){
        int x,y;
        scanf("%s%s%s%d%d",sa,sb,sc,&x,&y);
        if(mp.count(sa)==0) mp[sa] = ++ k;
        if(mp.count(sb)==0) mp[sb] = ++ k;
        add(mp[sb],mp[sa],x,y);
        deg[mp[sa]] ++;
    }
    for(int i = 1; i <= k; i ++) a[i] = inf,c[i]=0;
    queue<int>q;
    for(int i = 1; i <= k; i ++){
        if(!deg[i]){
            q.push(i); a[i] = c[i] = 0;
        }
    }
    while(!q.empty()){
        int u = q.front(); q.pop();
        for(int i = head[u]; ~i; i = edge[i].next){
            int v = edge[i].v;
            if(a[v]>a[u]+edge[i].cost || (a[v] == a[u]+edge[i].cost) && c[v]<c[u]+edge[i].value){
                a[v] = a[u] + edge[i].cost;
                c[v] = c[u] + edge[i].value;
            }
            if(! -- deg[v]) q.push(v);
        }
    }
    for(int i = 1; i <= k; i ++){
        for(int j = b; j >= a[i]; j--){
            dp[j] = max(dp[j],dp[j-a[i]]+c[i]);
        }
    }
    long long ans1=-1,ans2=0;
    for(int i = b; i >= 0; i --){
        if(ans1 <= dp[i]) ans1=dp[i],ans2=i;
    }
    printf("%lld %lld\n",ans1,ans2);
    return 0;
}

 

 

 

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值