1088 Rational Arithmetic

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.

Input Specification:
Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.

Output Specification:
For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.

Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

如何接受输入的字符?
如何将数转化为标准输出型?

分母和分子得是最简形式,同除最大公约数。
求最大公约数的方法:辗转相除法

注:gcd是求最大公约数,
reduction是化简成最简形式;
shower是将化成的最简型输出,其中未包含分母等于0的情况,
只有除法会有故特殊给出。
要得到输入的分子和分母可以按照格式化接受输入和输出。

#include<cstdio>
#include<math.h>
#include<algorithm>
using namespace std;
 
typedef long long ll;
struct fraction{
	ll up, dowm;
}a, b;
 
ll gcd(ll a, ll b){
	if(b==0)return a;
	else return gcd(b, a%b);
}
 
fraction reduction(fraction result){
	if(result.dowm<0){
		result.dowm*=-1;
		result.up*=-1;
	}
	if(result.up==0) result.dowm=1;
	else{
		int d=gcd(abs(result.up ), abs(result.dowm));
		result.up/=d;
		result.dowm/=d;
	}
	return result;
}
 
fraction add(fraction f1, fraction f2){
	fraction result;
	result.up=f1.up*f2.dowm+f2.up*f1.dowm;
	result.dowm=f1.dowm*f2.dowm;
	return reduction(result);
}
 
fraction minu(fraction f1, fraction f2){
	fraction result;
	result.up=f1.up*f2.dowm-f2.up*f1.dowm;
	result.dowm=f1.dowm*f2.dowm;
	return reduction(result);
}
 
fraction multi(fraction f1, fraction f2){
	fraction result;
	result.up=f1.up*f2.up;
	result.dowm=f1.dowm*f2.dowm;
	return reduction(result);
}
 
fraction devide(fraction f1, fraction f2){
	fraction result;
	result.up=f1.up*f2.dowm;
	result.dowm=f1.dowm*f2.up;
	return reduction(result);
}
 
void showresult(fraction r){
	r=reduction(r);    				//这里要给r赋值, 不然不返回。。。迷惑 
	if(r.up<0)printf("(");
	if(r.dowm==1)printf("%lld", r.up);
	else if(abs(r.up)>r.dowm){
		printf("%lld %lld/%lld", r.up/r.dowm, abs(r.up)%r.dowm, r.dowm);
	} else{
		printf("%lld/%lld", r.up, r.dowm);
	}
	if(r.up<0)printf(")");	
}
 
int main(){
	scanf("%lld/%lld %lld/%lld", &a.up, &a.dowm, &b.up, &b.dowm);
	showresult(a);
	printf(" + ");
	showresult(b);
	printf(" = ");
	showresult(add(a, b));
	printf("\n");
	
	showresult(a);
	printf(" - ");
	showresult(b);
	printf(" = ");
	showresult(minu(a, b));
	printf("\n");
	
	showresult(a);
	printf(" * ");
	showresult(b);
	printf(" = ");
	showresult(multi(a, b));
	printf("\n");
	
	showresult(a);
	printf(" / ");
	showresult(b);
	printf(" = ");
	if(b.up==0)printf("Inf");
	else showresult(devide(a, b));
	return 0;	
	
}
 

代码连接:https://blog.csdn.net/Chuyuan_li/article/details/81273197

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值