03-树2. List Leaves (25)

03-树2. List Leaves (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
8000 B
判题程序
Standard
作者
CHEN, Yue

Given a tree, you are supposed to list all the leaves in the order of top down, and left to right.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N-1. Then N lines follow, each corresponds to a node, and gives the indices of the left and right children of the node. If the child does not exist, a "-" will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in one line all the leaves' indices in the order of top down, and left to right. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6
Sample Output:
4 1 5


#include <stdio.h>
#include <ctype.h>
struct Node {
	int root;		//记录节点是否是根节点
	int left;
	int right;
};
int main() {
//	freopen("test.txt", "r", stdin);
	int n;
	struct Node nodes[10];
	scanf("%d", &n);
	for (int i = 0; i < n; ++i) {		//初始化树节点
		nodes[i].root = 1;				//没连接的节点都是根节点
		nodes[i].left = -1;				//没连接的节点左右儿子都为空
		nodes[i].right = -1;
	}
	for (int i = 0; i < n; ++i) {		//构造树
		char ch1, ch2;
		scanf("\n%c %c", &ch1, &ch2);
		if (isdigit(ch1)) {				//如果左儿子存在,将左儿子连接至该节点
			nodes[i].left = ch1 - '0';	//指针指向左儿子
			nodes[ch1 - '0'].root = 0;	//左儿子取消根节点标记
		}
		if (isdigit(ch2)) {
			nodes[i].right = ch2 - '0';
			nodes[ch2 - '0'].root = 0;
		}
	}
	int root;
	for (int i = 0; i < n; ++i)			//找到树根
		if (nodes[i].root == 1) {
			root = i;
			break;
		}
	//构造完树后,层序遍历树,依次输出叶节点;层序遍历过程:从根节点开始依次将左右儿子入队,直到队列为空
	int leaves = 0;			//记录输出叶节点个数,方便输出时第一个节点输出前没有空格
	int queue[10];			//节点队列,只保存节点下标
	int head = 0, rear = 0;
	queue[rear++] = root;	//根节点入队
	while (rear - head) {
		int node = queue[head++];		//队首节点出队
		if (nodes[node].left == -1 && nodes[node].right == -1) {	//输出叶节点
			if (leaves)
				printf(" ");
			printf("%d", node);
			++leaves;
		}
		if (nodes[node].left != -1) {		//如果存在,左儿子入队
			queue[rear++] = nodes[node].left;
		}
		if (nodes[node].right != -1) {		//如果存在,右儿子入队
			queue[rear++] = nodes[node].right;
		}
	}
	return 0;
}


  • 6
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值