PAT甲级1007 Maximum Subsequence Sum

题目:

Given a sequence of K integers { N1​, N2​, ..., NK​ }. A continuous subsequence is defined to be { Ni​, Ni+1​, ..., Nj​ } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:

10
-10 1 2 3 4 -5 -23 3 7 -21

Sample Output:

10 1 4

解析:

求给定序列的最大子列和,并输出该子列的第一个值和最后一个。

题目约定:如果序列的所有值都是负数,则最大子列和为0,输出整个序列的第一个值和最后一个。

每输入一个就处理一个,避免超时。

一个很容易理解的原理:如果一个子序列的和为负数,用它继续求累加和的结果,要小于重新开始结算累加和。所以在顺序处理过程中,如果累加和为负数,则直接丢弃该段,从0开始重新计算累加和。

答案:

#include<stdio.h>
#include<iostream>

using namespace std;

int main()
{
    int max_first,max_last,max_sum=0;//最大子列和的开始、结束、和
    int line_first,line_last;//整个序列的开始、结束(只在全负的情况下有效)
    int sum=0;
    
    int k,temp;
    int first;//暂存子序列的开始
    
    cin>>k;//处理第一行输入
    
    cin>>temp;//读入序列的第一个数并处理
    max_first=temp;
    max_last=temp;
    max_sum=temp;
    line_first=temp;
    line_last=temp;
    
    if(temp>0)
    {
        sum=temp;//负数直接舍去
    }
    
    for(int i=1;i<k;i++)//依次处理之后的输入
    {
        cin>>temp;
        
        if(sum==0)//如果之前的序列已丢弃
        {
            first=temp;//记录新的序列首
        }
        
        if(line_last<0&&temp<0)//目前为止全为负数
        {
            //读取到序列中的第一个非负数时会破坏temp<0条件
            //故只在全负情况下有效
            line_last=temp;//则更新全队列的队尾
        }
        
        sum=sum+temp;
        
        if(sum>max_sum)//新的最大子列和,更新记录
        {
            max_sum=sum;
            max_first=first;
            max_last=temp;
        }
        
        if(sum<0)
        {
            sum=0;
        }//丢弃和为负数的子列
    }
    
    if(max_sum<0)
    {
        cout<<"0 "<<line_first<<" "<<line_last;
        //序列全为负数按照题目约定输出
    }
    else
    {
        cout<<max_sum<<" "<<max_first<<" "<<max_last;
        //有非负数则按照最大子列输出
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值