PAT_B_1034 有理数四则运算 (20 分)

本题要求编写程序,计算 2 个有理数的和、差、积、商。

输入格式:

输入在一行中按照 a1/b1 a2/b2 的格式给出两个分数形式的有理数,其中分子和分母全是整型范围内的整数,负号只可能出现在分子前,分母不为 0。

输出格式:

分别在 4 行中按照 有理数1 运算符 有理数2 = 结果 的格式顺序输出 2 个有理数的和、差、积、商。注意输出的每个有理数必须是该有理数的最简形式 k a/b,其中 k 是整数部分,a/b 是最简分数部分;若为负数,则须加括号;若除法分母为 0,则输出 Inf。题目保证正确的输出中没有超过整型范围的整数。

输入样例 1:

2/3 -4/2

输出样例 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

输入样例 2:

5/3 0/6

输出样例 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

本题易出问题点:注意分子分母类型,因为做乘除计算时,分子分母可能会超过int型,所以要设置longlong 

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <math.h>
using namespace std;
struct Fraction{    //分数
    long long up,down;    //分子、分母
};
//最大公约数
long long gcd(long long a,long long b)
{
    return !b?a:gcd(b,a%b);
}
//化简
Fraction reduction(Fraction result)
{
    if(result.down<0){          //分母为负数,令分子和分母都变为相反数
        result.up=-result.up;
        result.down=-result.down;
    }
    if(result.up==0){           //如果分子为0
        result.down=1;          //令分母为1
    }else{                      //如果分子不为0,进行约分
        long long d=gcd(abs(result.up),abs(result.down)); //分子分母的最大公约数
        result.up /= d;         //约去最大公约数
        result.down /= d;
    }
    return result;
}
Fraction add(Fraction f1,Fraction f2)
{
    Fraction result;
    result.up=f1.up*f2.down+f2.up*f1.down;
    result.down=f1.down*f2.down;
    return reduction(result);
}
Fraction minu(Fraction f1,Fraction f2)
{
    Fraction result;
    result.up=f1.up*f2.down-f2.up*f1.down;
    result.down=f1.down*f2.down;
    return reduction(result);
}
Fraction multi(Fraction f1,Fraction f2)
{
    Fraction result;
    result.up=f1.up*f2.up;
    result.down=f1.down*f2.down;
    return reduction(result);
}
Fraction divide(Fraction f1,Fraction f2)
{
    Fraction result;
    result.up=f1.up*f2.down;
    result.down=f1.down*f2.up;
    return reduction(result);
}
void showResult(Fraction r)
{
    r=reduction(r);
    if(r.down==1)
    {
        if(r.up<0||r.down<0) printf("(%lld)",r.up);
        else printf("%lld",r.up);
    }
    else if(abs(r.up)>r.down){
        if(r.up<0||r.down<0) printf("(%d %d/%d)",r.up/r.down,abs(r.up)%r.down,r.down);
        else printf("%d %d/%d",r.up/r.down,abs(r.up)%r.down,r.down);
    }else{
        if(r.up<0||r.down<0) printf("(%d/%d)",r.up,r.down);
        else printf("%d/%d",r.up,r.down);
    }
}
int main()
{
    char nums[50];
    cin.getline(nums,50);
    int len=strlen(nums);
    int isfirst=1,firstseg,secondseg,space;
    int firstneg=0,secondneg=0,firststart=0,secondstart;
    for(int i=0;i<len;i++)
    {
        if(nums[i]==' ') space=i;
        if(nums[i]=='/')
        {
            if(isfirst)
            {
                firstseg=i;
                isfirst=0;
            }
            else secondseg=i;
        }
    }
    if(nums[0]=='-')
    {
        firstneg=1;
        firststart=1;
    }
    if(nums[space+1]=='-')
    {
        secondneg=1;
        secondstart=space+2;
    }
    else secondstart=space+1;
    Fraction f1,f2;
    f1.up=0;f1.down=0;
    f2.up=0;f2.down=0;
    for(int i=0;i<firstseg-firststart;i++)
    {
        f1.up+=pow(10,i)*(nums[firstseg-1-i]-'0');
    }
    if(firstneg) f1.up*=(-1);
    for(int i=0;i<space-firstseg-1;i++)
    {
        f1.down+=pow(10,i)*(nums[space-1-i]-'0');
    }

    for(int i=0;i<secondseg-secondstart;i++)
    {
        f2.up+=pow(10,i)*(nums[secondseg-1-i]-'0');
    }
    if(secondneg) f2.up*=(-1);
    for(int i=0;i<len-secondseg-1;i++)
    {
        f2.down+=pow(10,i)*(nums[len-1-i]-'0');
    }
    Fraction result;
//第一行
    showResult(f1);
    printf(" + ");
    showResult(f2);
    printf(" = ");
    result=add(f1,f2);
    showResult(result);
    printf("\n");
//第二行
    showResult(f1);
    printf(" - ");
    showResult(f2);
    printf(" = ");
    result=minu(f1,f2);
    showResult(result);
    printf("\n");
//第三行
    showResult(f1);
    printf(" * ");
    showResult(f2);
    printf(" = ");
    result=multi(f1,f2);
    showResult(result);
    printf("\n");
//第四行
    showResult(f1);
    printf(" / ");
    showResult(f2);
    printf(" = ");
    result=divide(f1,f2);
    if(f2.up==0) printf("Inf");
    else showResult(result);
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
REGISTER ADDRESS REGISTER DATA(1) HEX 15 14 13 12 11 10 9 8 7 6 5 4 3 2 1 0 1 0 LVDS_ RATE_2X 0 0 0 0 0 0 0 0 0 0 0 0 0 GLOBAL_ PDN 2 PAT_MODES_FCLK[2:0] LOW_ LATENCY_E N AVG_EN SEL_PRBS_ PAT_ FCLK PAT_MODES SEL_PRBS_ PAT_GBL OFFSET_CORR_DELAY_FROM_TX_TRIG[5:0] 3 SER_DATA_RATE DIG_GAIN_ EN 0 OFFSET_CORR_DELAY _FROM_TX_TRIG[7:6] DIG_ OFFSET_ EN 0 0 0 1 0 0 0 0 4 OFFSET_ REMOVA L_SELF OFFSET_ REMOVAL_ START_ SEL OFFEST_ REMOVAL_ START_ MANUAL AUTO_OFFSET_REMOVAL_ACC_CYCLES[3:0] PAT_ SELECT_ IND PRBS_ SYNC PRBS_ MODE PRBS_EN MSB_ FIRST DATA_ FORMAT 0 ADC_RES 5 CUSTOM_PATTERN 7 AUTO_OFFSET_REMOVAL_VAL_RD_CH_SEL 0 0 0 0 0 0 0 0 0 0 CHOPPER_EN 8 0 0 AUTO_OFFSET_REMOVAL_VAL_RD B 0 0 0 0 EN_ DITHER 0 0 0 0 0 0 0 0 0 0 0 D GAIN_ADC1o 0 OFFSET_ADC1o E GAIN_ADC1e 0 OFFSET_ADC1e F GAIN_ADC2o 0 OFFSET_ADC2o 10 GAIN_ADC2e 0 OFFSET_ADC2e 11 GAIN_ADC3o 0 OFFSET_ADC3o 12 GAIN_ADC3e 0 OFFSET_ADC3e 13 GAIN_ADC4o 0 OFFSET_ADC4o 14 GAIN_ADC4e 0 OFFSET_ADC4e 15 PAT_PRB S_LVDS1 PAT_PRBS_ LVDS2 PAT_PRBS_ LVDS3 PAT_PRBS_ LVDS4 PAT_LVDS1 PAT_LVDS2 HPF_ ROUND_ EN_ADC1-8 HPF_CORNER_ADC1-4 DIG_HPF_ EN_ADC1-4 17 0 0 0 0 0 0 0 0 PAT_LVDS3 PAT_LVDS4 0 0 18 0 0 0 0 PDN_ LVDS4 PDN_ LVDS3 PDN_ LVDS2 PDN_ LVDS1 0 0 0 0 INVERT_ LVDS4 INVERT_ LVDS3 INVERT_ LVDS2 INVERT_ LVDS1 19 GAIN_ADC5o 0 OFFSET_ADC5o 1A GAIN_ADC5e 0 OFFSET_ADC5e 1B GAIN_ADC6o 0 OFFSET_ADC6o 1C GAIN_ADC6e 0 OFFSET_ADC6e 1D GAIN_ADC7o 0 OFFSET_ADC7o 1E GAIN_ADC7e 0 OFFSET_ADC7e 1F GAIN_ADC8o 0 OFFSET_ADC8o 20 GAIN_ADC8e 0 OFFSET_ADC8e 21 PAT_PRB S_LVDS5 PAT_PRBS_ LVDS6 PAT_PRBS_ LVDS7 PAT_PRBS_ LVDS8 PAT_LVDS5 PAT_LVDS6 0 HPF_CORNER_ADC5-8 DIG_HPF_ EN_ADC5-8 23 0 0 0 0 0 0 0 0 PAT_LVDS7 PAT_LVDS8 0 0
最新发布
06-09

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值