L1-017 到底有多二-java

输入样例:

-13142223336

输出样例:

81.82%


import java.util.Scanner;

public class Main {
public static void main(String[] args) {
	Scanner scanner = new Scanner(System.in);
	String str=scanner.next();
	char[] c=str.toCharArray();
	int count =0;
	double res;
	for(int i=0;i<c.length;i++) {
		if(c[i]=='2') {
			count++;
		}
	}
	if(c[0]=='-') {
		if(c[str.length()-1]%2==0) {
			res=1.0*count/(c.length-1)*100*1.5*2;
			System.out.printf("%.2f",res);
			System.out.print("%");
		}else {
			res=1.0*count/(c.length-1)*100*1.5;
			System.out.printf("%.2f",res);
			System.out.print("%");
		}
	}else {
		if(c[str.length()-1]%2==0) {
			res=1.0*count/c.length*100*2;
			System.out.printf("%.2f",res);
			System.out.print("%");
		}else {
			res=1.0*count/c.length*100;
			System.out.printf("%.2f",res);
			System.out.print("%");
		}
	}
}
}

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值