L1-020 帅到没朋友_java

输入样例1:

3
3 11111 22222 55555
2 33333 44444
4 55555 66666 99999 77777
8
55555 44444 10000 88888 22222 11111 23333 88888

输出样例1:

10000 88888 23333

输入样例2:

3
3 11111 22222 55555
2 33333 44444
4 55555 66666 99999 77777
4
55555 44444 22222 11111

输出样例2:

No one is handsome

 java

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {

    public static void main(String[] args) throws IOException {
        BufferedReader reader = new BufferedReader(new InputStreamReader(System.in));
        boolean[] flag = new boolean[100001];
        boolean F = true;
        int n = Integer.parseInt(reader.readLine());
        for (int i = 0; i < n; i++) {
            String[] str = reader.readLine().split(" ");
            int m = Integer.parseInt(str[0]);
            if (m != 1)
                for (int j = 1; j <= m; j++)
                    flag[Integer.parseInt(str[j])] = true;
        }
        n = Integer.parseInt(reader.readLine());
        String[] str = reader.readLine().split(" ");
        for (int i = 0; i < n; i++) {
            if (!flag[Integer.parseInt(str[i])]) {
                if (F == false)
                    System.out.print(" ");
                System.out.printf(str[i]);
                flag[Integer.parseInt(str[i])] = true;
                F = false;
            }
        }
        if (F)
            System.out.println("No one is handsome");
    }
}

  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值