L1-023 输出GPLT-java

 

输入样例:

pcTclnGloRgLrtLhgljkLhGFauPewSKgt

输出样例:

GPLTGPLTGLTGLGLL

思路

设置一个GPLT的计数器
然后遍历的时候每次对计数器的个数减一
import java.io.*;

public class Main {
    public static void main(String[] args) throws IOException {
        BufferedReader bf = new BufferedReader(new InputStreamReader(System.in));
        String str = bf.readLine().toUpperCase();
        //定义一个计数器,分别计算GPLT的个数
        int[] count = new int[4];
        for (int i = 0; i < str.length(); i++) {
            if(str.charAt(i) == 'G'){
                count[0]++;
            } else if(str.charAt(i) == 'P'){
                count[1]++;
            } else if(str.charAt(i) == 'L'){
                count[2]++;
            } else if(str.charAt(i) == 'T'){
                count[3]++;
            }
        }
        //找出四个字母中个数最多的字母
        int max = Math.max(Math.max(count[0], count[1]), Math.max(count[2], count[3]));
        for (int i = 0; i < max; i++) {
            if(count[0]--> 0){
                System.out.print("G");
            }
            if(count[1]--> 0){
                System.out.print("P");
            }
            if(count[2]--> 0){
                System.out.print("L");
            }
            if(count[3]--> 0){
                System.out.print("T");
            }
        }
    }
}

 

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值